This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 174103 - Screen saver not disabled with xset s off & xset -dpms
Screen saver not disabled with xset s off & xset -dpms
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks: xorg-modular
  Show dependency treegraph
 
Reported: 2005-11-24 11:08 EST by Henri Ala-Peijari
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 13:20:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Henri Ala-Peijari 2005-11-24 11:08:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7

Description of problem:
The screen goes blank even though I've entered xset s off and xset -dpms on the console window which disables blanking in earlier FedoraCore distributions.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.type xset s off + xset -dpms on the root console
2.wait
3.screen goes blank
  

Actual Results:  Screen goes blank

Expected Results:  Screen stays on, no screen saver, no power management

Additional info:
Comment 1 Mike A. Harris 2005-11-24 11:57:05 EST
Please file a bug report in X.Org bugzilla, at http://bugs.freedesktop.org in
the "xorg" component.  In your bug report, indicate that you are using the
X11R7 RC2 release (6.99.99.902), and attach your X server log and config file.
Since X11R7 is in freeze right now, be sure to flag your bug report as
blocking bug 1690, the release blocker bug.

Once you've filed your report to X.Org, please paste the URL here and
Red Hat will track the upstream bug report, and review any fixes that
become available for consideration in future builds for Fedora.

Thanks in advance.



Setting status to "NEEDINFO_REPORTER", and awaiting upstream
bug URL for tracking.
Comment 2 Henri Ala-Peijari 2005-11-24 14:21:16 EST
https://bugs.freedesktop.org/show_bug.cgi?id=5154
Comment 3 Henri Ala-Peijari 2005-11-24 15:51:15 EST
Ok, so it seems that there's a component on the desktop environment that
controls the screen saver as well and that has to be set also to allow the
screen to stay on. I'm not sure if this is a bug, but ofcourse it would be nice
if the "xset s off" + "xset -dpms" would do the job without additional work
elsewhere.
Comment 4 Mike A. Harris 2006-01-31 13:20:14 EST
Any application can enable or disable DPMS, or configure it via X protocol.

xset is only one application which allows you to set DPMS.  There is no
way to prevent other applications from modifying the DPMS settings, as there
is no way to know which client is connecting, in order to allow/deny based
on the client.  It wouldn't be desireable to do this anyway, as some people
use and prefer to use xset, while other people prefer to do things via GNOME
or KDE control panels, or some other desktop system.

This is not a bug, but is a feature of the X Window System, much in the same
way that any application can set the wallpaper on the root window, or any
one of a number of other settings.

Since it appears you've discovered some other application was affecting
the DPMS settings, I'm concluding this is not a bug, and setting the
status to reflect.

Setting status to "NOTABUG"

Note You need to log in before you can comment on or make changes to this bug.