Bug 1741069 - [4.1.z]openshift-samples clusteroperator degraded reporting missing reason/detail information
Summary: [4.1.z]openshift-samples clusteroperator degraded reporting missing reason/de...
Keywords:
Status: CLOSED DUPLICATE of bug 1742907
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: ImageStreams
Version: 4.1.z
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.z
Assignee: Gabe Montero
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-14 08:03 UTC by Junqi Zhao
Modified: 2019-08-17 13:46 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1741062
Environment:
Last Closed: 2019-08-17 13:46:00 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 1 Gabe Montero 2019-08-16 15:58:27 UTC
Ben - do you agree that the setting the missing reason/detailed message fix should be backported to 4.1.z?

Comment 2 Ben Parees 2019-08-16 17:17:48 UTC
this is specifically about the "Failed imports" degraded reason/message?  No i don't think that needs to be backported.

Comment 3 Ben Parees 2019-08-16 17:19:20 UTC
if we're entirely missing the "reason" field in 4.1.z telemeter for some operator (is this for the registry operator, or the samples operator? or some other operator?  hard to tell from the report), then yes that should be backported.

Comment 4 Gabe Montero 2019-08-16 17:34:37 UTC
this is the degraded reason field for the samples operator (which will occur if imports has failed 

so assuming #comment 3 trumps #comment 2 then I'll backport

Comment 5 Ben Parees 2019-08-16 17:46:41 UTC
> so assuming #comment 3 trumps #comment 2 then I'll backport

Sorry for the confusion.

What I was trying to say is:

We do not need to backport the logic around the samples operator marking itself as degraded(with a reason) when imports failed.  I don't think covering that specific failure is that important that we'd backport it to 4.1.z.


If we have operators that are not reporting reasons for their conditions (ie they don't report a reason for their condition), that would need to be backported.

It sounds like we are all good here and this can be closed as won't fix in 4.1.z.

Comment 6 Gabe Montero 2019-08-16 17:56:21 UTC
That clarification helped thanks ... that said, I think I've contributed some confusion as well

Let me try to elaborate:
1) while this problem was more noticeable *AFTER* samples operator started reporting degraded after 2 hours if the imports were failing ...
2) ... if samples operator was degraded for another reason, such as invalid config, missing credentials, or issues talking to the API server, it was missing the reason/detail

based on your clarifications, and my clarification above, I *WILL* backport to 4.1.z

Comment 7 Ben Parees 2019-08-16 18:06:52 UTC
> based on your clarifications, and my clarification above, I *WILL* backport to 4.1.z

got it, yes sounds like the right thing to do.

Comment 8 Gabe Montero 2019-08-17 13:46:00 UTC
To facilitate the cherrypick / patch manager process, I've clone the 4.2 bug https://bugzilla.redhat.com/show_bug.cgi?id=1739214 to https://bugzilla.redhat.com/show_bug.cgi?id=1742907

this bug will be addressed by that one

*** This bug has been marked as a duplicate of bug 1742907 ***


Note You need to log in before you can comment on or make changes to this bug.