Bug 1742907 - samples operator clusteroperator degraded reporting missing reason/detail information
Summary: samples operator clusteroperator degraded reporting missing reason/detail inf...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Templates
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.1.z
Assignee: Gabe Montero
QA Contact: XiuJuan Wang
URL:
Whiteboard:
: 1741069 (view as bug list)
Depends On: 1739214
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-17 13:43 UTC by Gabe Montero
Modified: 2019-08-28 19:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The samples operator was not setting the reason/message information it generated for various errors it detected on its ClusterOperator object's Degraded condition. Consequence: Useful diagnostic information on the samples operator was not readily available from the telemetry console. Fix: The reason/message information when the samples operator detects errors is not being set on its ClusterOperator object's Degraded condition. Result: Useful diagnositc information on the samples operator is not available from the telemetry console.
Clone Of: 1739214
Environment:
Last Closed: 2019-08-28 19:55:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2547 None None None 2019-08-28 19:55:07 UTC
Github openshift cluster-samples-operator pull 175 None None None 2019-08-17 14:13:31 UTC

Comment 1 Gabe Montero 2019-08-17 13:46:00 UTC
*** Bug 1741069 has been marked as a duplicate of this bug. ***

Comment 2 Gabe Montero 2019-08-17 13:48:08 UTC
cherrypick bot unsuccessful in backporting 4.2 PR to 4.1:  https://github.com/openshift/cluster-samples-operator/pull/167#issuecomment-522238470

manually picking

Comment 4 XiuJuan Wang 2019-08-23 02:31:48 UTC
@Gabe Since https://bugzilla.redhat.com/show_bug.cgi?id=1738646 won't fix in 4.1.z, so I have no idea how to make the openshift-samples degrade.
Could you help me give a clew?
Thanks

Comment 5 Gabe Montero 2019-08-23 13:34:26 UTC
Responded in the google doc as well @XiuJuan but for completeness, and invalid config, like an invalid architecture value/setting, should produce and invalid config and report degraded

Comment 6 XiuJuan Wang 2019-08-23 16:14:20 UTC
Gabe, thanks
Could verified this in 4.1.0-0.nightly-2019-08-21-150150
    Last Transition Time:  2019-08-23T16:11:29Z
    Message:               Samples installation in error at 4.1.0-0.nightly-2019-08-21-150150: invalid configuration
    Status:                True
    Type:                  Progressing
    Last Transition Time:  2019-08-23T16:11:29Z
    Message:               Samples installation in error at 4.1.0-0.nightly-2019-08-21-150150: architecture ppc64 unsupported; only support x86_64
    Reason:                invalid configuration
    Status:                True
    Type:                  Degraded

Comment 8 errata-xmlrpc 2019-08-28 19:55:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2547


Note You need to log in before you can comment on or make changes to this bug.