Bug 1741148 - [downstream clone - 4.3.7] Memory snapshots' deletion logging unnecessary WARNINGS in engine.log
Summary: [downstream clone - 4.3.7] Memory snapshots' deletion logging unnecessary WAR...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.2.8-2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.3.7
: 4.3.7
Assignee: Pavel Bar
QA Contact: Avihai
URL:
Whiteboard:
Depends On: 1686650
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-14 11:23 UTC by RHV bug bot
Modified: 2020-08-03 15:31 UTC (History)
5 users (show)

Fixed In Version: ovirt-engine-4.3.7.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1686650
Environment:
Last Closed: 2019-12-12 10:36:34 UTC
oVirt Team: Storage
Target Upstream Version:
lsvaty: testing_plan_complete-


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:4229 0 None None None 2019-12-12 10:37:02 UTC
oVirt gerrit 101243 0 'None' MERGED core: Duplicated call for removing a memory_metadata volume 2020-03-30 12:36:51 UTC
oVirt gerrit 101443 0 'None' MERGED core: Duplicated call for removing a memory_metadata volume 2020-03-30 12:36:51 UTC
oVirt gerrit 102315 0 'None' MERGED core: Deleting memory snapshot logs unnecessary warnings 2020-03-30 12:36:51 UTC
oVirt gerrit 103190 0 'None' MERGED core: Deleting memory snapshot logs unnecessary warnings 2020-03-30 12:36:51 UTC

Description RHV bug bot 2019-08-14 11:23:59 UTC
+++ This bug is a downstream clone. The original bug is: +++
+++   bug 1686650 +++
======================================================================

Description of problem:

Customer complains of the following warning in engine.log causing grief and unnecessary panic about the stability of their RHEV environment 

'
2019-03-07 17:24:56,587-05 WARN  [org.ovirt.engine.core.bll.storage.disk.RemoveDiskCommand] (EE-ManagedThreadFactory-commandCoordinator-Thread-8) [36fef594] Validation of action 'RemoveDisk' failed for user admin@internal-authz. Reasons: VAR__ACTION__REMOVE,VAR__TYPE__DISK,ACTION_TYPE_FAILED_VM_IMAGE_DOES_NOT_EXIST

2019-03-07 17:25:37,855-05 WARN  [org.ovirt.engine.core.bll.ReduceImageCommand] (EE-ManagedThreadFactory-engineScheduled-Thread-55) [] Validation of action 'ReduceImage' failed for user admin@internal-authz. Reasons: VAR__TYPE__STORAGE__DOMAIN,ACTION_TYPE_FAILED_REDUCE_IMAGE_NOT_SUPPORTED_FOR_ACTIVE_IMAGE_LIVE_MERGE

"

They see these messages everytime they delete a snapshot. The snapshot deletion on the other hand completes successfully on the host.


Version-Release number of selected component (if applicable):

RHEV release:     4.2.8.2-0.1.el7ev

How reproducible:

Always

Steps to Reproduce:
1. Create a snapshot on an active VM. This will ensure that the memory snapshot disks are created

2. Now go ahead and delete this created snapshot.

3. the engine.log file will have the messages mentioned.

(Originally by Anitha Udgiri)

Comment 1 RHV bug bot 2019-08-14 11:24:01 UTC
Request that due diligence is done to these messages and suppressed as this causes a lot of misunderstanding .

(Originally by Anitha Udgiri)

Comment 2 RHV bug bot 2019-08-14 11:24:03 UTC
I have attached the vdsm.log and engine.log file from the Customer's env. Let me now if you need anything else.

(Originally by Anitha Udgiri)

Comment 5 RHV bug bot 2019-08-14 11:24:07 UTC
The committed patch https://gerrit.ovirt.org/#/c/102315/ fixes the "ReduceImage" warning.
The "RemoveDisk" warning was already fixed in https://bugzilla.redhat.com/1704819 by Shani.

(Originally by Pavel Bar)

Comment 6 Daniel Gur 2019-08-28 13:15:26 UTC
sync2jira

Comment 7 Daniel Gur 2019-08-28 13:21:13 UTC
sync2jira

Comment 9 RHV bug bot 2019-10-18 12:03:49 UTC
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Tag 'ovirt-engine-4.3.7.0' doesn't contain patch 'https://gerrit.ovirt.org/101243']
gitweb: https://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=shortlog;h=refs/tags/ovirt-engine-4.3.7.0

For more info please contact: rhv-devops@redhat.com

Comment 11 RHV bug bot 2019-10-24 16:33:54 UTC
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Tag 'ovirt-engine-4.3.7.0' doesn't contain patch 'https://gerrit.ovirt.org/101243']
gitweb: https://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=shortlog;h=refs/tags/ovirt-engine-4.3.7.0

For more info please contact: rhv-devops@redhat.com

Comment 12 Tal Nisan 2019-10-29 14:35:52 UTC
It appears the bot started to check the patches against the tag, this will most likely cause us lots of headaches in the future

Comment 13 Avihai 2019-10-31 14:09:23 UTC
Verified on 4.3.7.0-0.1.el7.

Ran the same scenario and the describe WARN level errors in the engine log were NOT seen. 

Scenario:
1. Create a snapshot on an active VM. This will ensure that the memory snapshot disks are created
2. Now go ahead and delete this created snapshot.
3. Check if the engine.log file will have the messages mentioned.

Comment 14 RHV bug bot 2019-11-01 09:31:59 UTC
INFO: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[Tag 'ovirt-engine-4.3.7.1' doesn't contain patch 'https://gerrit.ovirt.org/101243']
gitweb: https://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=shortlog;h=refs/tags/ovirt-engine-4.3.7.1

For more info please contact: rhv-devops@redhat.com

Comment 15 RHV bug bot 2019-11-14 11:10:02 UTC
INFO: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[Tag 'ovirt-engine-4.3.7.2' doesn't contain patch 'https://gerrit.ovirt.org/102315']
gitweb: https://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=shortlog;h=refs/tags/ovirt-engine-4.3.7.2

For more info please contact: rhv-devops@redhat.com

Comment 17 errata-xmlrpc 2019-12-12 10:36:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:4229


Note You need to log in before you can comment on or make changes to this bug.