This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 174120 - <gnu/stubs-32.h> is missing
<gnu/stubs-32.h> is missing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 174122 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-24 13:44 EST by John Reiser
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-24 14:25:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2005-11-24 13:44:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
Neither glibc-devel-2.3.90-18 nor glibc-headers-2.3.90-18 for x86_64 contains /usr/include/gnu/stubs-32.h which is #include by <gnu/stubs.h> for -m32 compilations.


Version-Release number of selected component (if applicable):
glibc-devel-2.3.90-18

How reproducible:
Always

Steps to Reproduce:
1. gcc -m32 -c foo.c   # where foo.c: #include <gnu/stubs.h>
2.
3.
  

Actual Results:  /usr/include/gnu/stubs.h:7:27: error: gnu/stubs-32.h: No such file or directory


Expected Results:  No complaint.

Additional info:
Comment 1 Jakub Jelinek 2005-11-24 14:25:47 EST
It is provided by glibc-devel-*.i386.rpm.  If you want to build 32-bit programs,
you obviously need to have 32-bit devel environment installed.
gcc doesn't require it, because most users need just the 64-bit one.
Comment 2 Jakub Jelinek 2005-11-24 14:26:47 EST
*** Bug 174122 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.