Bug 174122 - /usr/lib/crt1.o is missing for -m32 development
/usr/lib/crt1.o is missing for -m32 development
Status: CLOSED DUPLICATE of bug 174120
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-24 14:02 EST by John Reiser
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-24 14:26:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2005-11-24 14:02:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
32-bit executables cannot be built on x86_64 because /usr/lib/crt1.o is missing.

Version-Release number of selected component (if applicable):
glibc-devel-2.3.90-18

How reproducible:
Always

Steps to Reproduce:
1. gcc -m32 hello.c
2.
3.
  

Actual Results:  /usr/bin/ld: crt1.o: No such file: No such file or directory


Expected Results:  No complaint, and successful static bind to produce 32-bit ELF executable.

Additional info:
Comment 1 Jakub Jelinek 2005-11-24 14:26:34 EST

*** This bug has been marked as a duplicate of 174120 ***

Note You need to log in before you can comment on or make changes to this bug.