This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 174136 - Pup dies on update
Pup dies on update
Status: CLOSED DUPLICATE of bug 174125
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-24 19:31 EST by Josh Boyer
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-24 22:34:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Josh Boyer 2005-11-24 19:31:12 EST
Description of problem:

Pup backtraced on a recent update.

Version-Release number of selected component (if applicable):

[jwboyer@yoda ~]$ rpm -q pup
pup-0.1.6-1

How reproducible:

Not sure.

Steps to Reproduce:
1. Start pup
2. Accept updates
3. Marvel at the lovely python backtrace
  
Actual results:

[root@yoda ~]# pup
Traceback (most recent call last):
  File "/usr/share/pup/pup/pup.py", line 536, in _apply
    self._checkDeps()
  File "/usr/share/pup/pup/pup.py", line 778, in _checkDeps
    _("Unable to resolve dependencies for some "
  File "/usr/share/pup/pup/pup.py", line 131, in __init__
    i.set_from_stock(self._get_stock_from_type(type), 6)
AttributeError: 'NoneType' object has no attribute 'set_from_stock'

> /usr/share/pup/pup/pup.py(131)__init__()
-> i.set_from_stock(self._get_stock_from_type(type), 6)
(Pdb)                
                                      
Expected results:

Update completes :)

Additional info:

I still have pup sitting at the python debugger propmpt.  I know very little
about using pdb, but I intend to leave it there in case there is something that
will help.
Comment 1 Jeremy Katz 2005-11-24 22:34:28 EST

*** This bug has been marked as a duplicate of 174125 ***
Comment 2 David Lawrence 2006-06-27 21:34:09 EDT
Moving component to pirut. Sorry for the spam.

Note You need to log in before you can comment on or make changes to this bug.