Bug 174231 - anaconda unhandled exception when checking partitions
anaconda unhandled exception when checking partitions
Status: CLOSED DUPLICATE of bug 170003
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-26 04:50 EST by Ross Kiester
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-26 17:19:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ross Kiester 2005-11-26 04:50:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/416.11 (KHTML, like Gecko) Safari/416.12

Description of problem:
I'm trying to install Fedora Core 4 on a MAC G-5 (dual processor, 1 gig main memory) coresident with 
MAC OS X Tiger (10.4)

The basic problem is that I cannot get the disk partitioned so that installation can proceed.

Here are the details:

Using Volume works the following partitions are found:

/dev/disk0s2
  Apple_Bootstrap: 1.0 MB
  
/dev/disk0s4
  Apple_UNIX_SVR2: 100.0 MB
  
/dev/disk0s6
  Apple_Free: 27.0 MB
  
/dev/dosk0s3 (OS X HD)
  Apple_HFS: 76.21GB
  
/dev/disk0s5
  Linux_LVM: 76.34 GB
  

Now using Fedora Core 4 PPC ISO DVD

...

boot: linux text

media check ... o.k. to install ..

running anaconda ...

... workstation ...
... autopartition ...

Exception Occurred

An unhandled exception has occurred. This is most likely a bug. Please copy ... and
file a report against anaconda at

http://bugzilla.redhat.com/bugzilla

Traceback ...

FILE "/usr/bin/anaconda", line 1160 in ? intf.run(id, dispatch)

FILE "/usr/lib/anaconda/text.py", line 496, in run dispatch.gotoNext()

FILE "/usr/lib/anaconda/dispatch.py", line 174 in gotoNext self.moveStep()

FILE "/usr/lib/anaconda//dispatch.py", line 242 in moveStep
     rc = apply(func, self.bindArgs(args))
     
FILE "/usr/lib/anaconda/partitioning.py, line 54 in partitionObjectsInitialize
     partitions.setFromDisk(diskset)
     
FILE "/usr/lib/anaconda/partitions.py", line 108 in setFromDisk
     ptype =
     parted.Utils.get_partition_file_system_type(part)
     
FILE "/usr/lib/anaconda/partedUtils.py", line 140 in get_partition_file_system_type
     elif (part get_flag(parted.PARTITION_BOOT == 1 and
     
Attribute Error: 'NoneType' object has no attribute 'name'
Comment 1 Jeremy Katz 2005-11-26 17:19:40 EST

*** This bug has been marked as a duplicate of 170003 ***

Note You need to log in before you can comment on or make changes to this bug.