Bug 174243 - Installation of AOpen XC Cube EX761 Fails, RAID sata_sis module fails to detect drives.
Installation of AOpen XC Cube EX761 Fails, RAID sata_sis module fails to dete...
Status: CLOSED DUPLICATE of bug 169613
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-26 07:05 EST by Carl-Johan Kjellander
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-26 13:01:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl-Johan Kjellander 2005-11-26 07:05:08 EST
Description of problem:
Trying to install FC3 and FC4 on a barebone machine,
AOpen XC Cube EX761 with a SiS RAID controller and 2 200 GB
disks in a RAID 1 configuration. I think it's a SiS 761 controller.

The installation fails when it can't autodetect the RAID
array so there are now drives to install to. It also fails 
to load sata_sis, but loading that module manually doesn't help.

FC4.90 loads sata_sis and detects the RAID array and installation
works fine. 

Version-Release number of selected component (if applicable):
FC3    kernel-2.6.9-1.667       Fails
FC4    kernel-2.6.11-1.1369_FC4 Fails
FC4.90 kernel-2.6.14-1.1696_FC5 Works

How reproducible:
Always

Steps to Reproduce:
1. Create a RAID array on a AOpen XC Cube EX761
2. Try to install FC3 or FC4
  
Actual results:
Kernel doesn't autodetect RAID Array, can't continue installation.

Expected results:
It should install on the RAID Array.

Additional info:
lspci shows: SiS: Unknown device 0761 (Rev 01)

Is is possible to create our own FC3/4 install boot.iso with the kernel
from FC4.90 ? How would that be done? Mounting it through a loop interface
and copying files?
Comment 1 Dave Jones 2005-11-26 13:01:13 EST
there's not much we can do for installation problems, as they need a newer kernel.
There are some unofficial ISOs available created by community members who have
built FC4+updates releases. The url is in the bug this is duped against.

Otherwise, you're out of luck until FC5.

Good luck.

*** This bug has been marked as a duplicate of 169613 ***

Note You need to log in before you can comment on or make changes to this bug.