This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 174244 - Lots of packages on FC5T1 install CDs but not all are in comps groups
Lots of packages on FC5T1 install CDs but not all are in comps groups
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-26 07:47 EST by Bernd Bartmann
Modified: 2013-01-09 20:20 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-01 15:02:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
list of packages that got not installed by FC5T1 although all package groups were selected for installation (24.10 KB, text/plain)
2005-11-26 07:48 EST, Bernd Bartmann
no flags Details
list of missing packages without version numbers (14.10 KB, text/plain)
2005-11-29 13:39 EST, Bernd Bartmann
no flags Details
development packages not inside a defined group (6.97 KB, text/plain)
2005-11-30 01:37 EST, Jef Spaleta
no flags Details
list of packages on the FC5T2 install CDs that were not installed although everything should have been installed (12.54 KB, text/plain)
2006-01-18 13:46 EST, Bernd Bartmann
no flags Details
list of rpms that are on the FC5T3 install CDs but did not get installed although "everything" install was selected (20.19 KB, text/plain)
2006-02-20 15:43 EST, Bernd Bartmann
no flags Details

  None (edit)
Description Bernd Bartmann 2005-11-26 07:47:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
I'm referring to the problems described in bug #16008 and #174092.
When selecting all package groups during FC5T1 install lots of packages that are on the install CDs are not getting installed (e.g. mc, smartmontools, ...)
I'll attach a complete list of the packages that did not get installed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. select all available package group when installing FC5T1
2. try to start mc or smartctl 
3.
  

Additional info:
Comment 1 Bernd Bartmann 2005-11-26 07:48:36 EST
Created attachment 121505 [details]
list of packages that got not installed by FC5T1 although all package groups were selected for installation
Comment 2 Matthew Miller 2005-11-26 09:35:30 EST
Changing summary from "not all can be installed", since there's no problem with
actually installing the packages -- they're just not pulled in by picking all of
the groups.

Many of these are language specific, and are already dealt with with
special-case code in anaconda. The rest are worthwhile examining for either
adding to a group or for moving to extras, but should be done on a case-by-case
basis. This could be used as a tracking bug for that.

Should be mentioned that this project is going to be more work than it may
appear at first.
Comment 3 Jeremy Katz 2005-11-26 11:10:08 EST
The methodology for finding the packages which aren't covered by a group used
here is flawed.  You do not want _every_ package listed in the comps file. 
Things which are just dependencies (think glibc, gtk+, etc) shouldn't be listed
-- they should just be selected automatically.  Also, there are a fair number of
packages which are optional and not default.  So they're listed in the comps
file and will be selectable once the package selection screen is reworked.

That's why there's thought and work required as opposed to it being a purely
mechanical exercise.
Comment 4 Jef Spaleta 2005-11-28 17:45:26 EST
Can you do me a favor and generate that list again with just the package names.
I want to to diff it against I list I'm making using repoquery on the moving
development tree... and I really don't want to have to try to screen-scrape the
name-version split.  If you can regenerate that packagelist and just have the
packagename that would be a wonderful.

-jef
Comment 5 Bernd Bartmann 2005-11-29 13:38:07 EST
Sure, here's what I did:

cat missing-packages.list | sed -e 's/-[^-]*-[^-]*$//' > missing-packages.list2
Comment 6 Bernd Bartmann 2005-11-29 13:39:12 EST
Created attachment 121605 [details]
list of missing packages without version numbers
Comment 7 Jef Spaleta 2005-11-30 01:37:40 EST
Created attachment 121627 [details]
development packages not inside a defined group

Okay I took at stab at using repoquery to find the set of packages in rawhide
that are not a dependancy of other packages and are not defined as part of a
group according repoquery's--groupmember and --leaves options.	Panu added the
--leaves option to repoquery at my request.

The run of --leaves gave me 916 packages, not including debuginfo. I then did a
brute force groupmemebership check using --groupmember on that list.  

Interesting points: 
460 packages in the set
154 -devel packages according to a simple grep
There are a number of scim packages that are not in groups, and a number which
are in groups.. all the other language related packages seems to be in a
language grouping.  

-jef
Comment 8 Jesse Keating 2005-12-14 12:19:19 EST
We are working to sort out exactly what to do w/ comps, and Jeremy is working on
the selection screen.  Most likely this problem will be resolved by test2 or
test3 timeframe.  I'll look at closing the bug then.
Comment 9 Jeremy Katz 2006-01-12 17:04:16 EST
I think I got the user-interesting ones out of here for test2.  
Comment 10 Bernd Bartmann 2006-01-18 13:45:14 EST
This situation is a little bit better on FC5T2 but there are still 846 packages
that don't get installed although I selected all possible categories,
sub-categories and option on the package selection screen. (BTW: I really want
the "Install everything" option back)

For me esp. the smartmontools package is not installed by default. This package
saved my data more than once by telling me the a disc is going to die soon. Now
with the current kernel that finally supports SMART command passthrough on SATA
discs the package is even more useful even on Joe user systems.

Please have a look at the list of packages that were not installed by FC5T2.
Comment 11 Bernd Bartmann 2006-01-18 13:46:27 EST
Created attachment 123395 [details]
list of packages on the FC5T2 install CDs that were not installed although everything should have been installed
Comment 12 Jef Spaleta 2006-01-20 15:33:18 EST
(In reply to comment #10)
> This situation is a little bit better on FC5T2 but there are still 846 packages
> that don't get installed although I selected all possible categories,

Did you ask for all languages to be installed as well in the language selection
portion of the install?


-jef
Comment 13 Bernd Bartmann 2006-01-20 15:45:27 EST
Good point. No I only selected German and English.
Comment 14 Jef Spaleta 2006-01-20 16:01:41 EST
yeah... a big chunk of your package list is language specific packages. It would
be noteworthy to do the "everything" install again with all langauges selected
and see if there are any language packs left which are not installed.

-jef
Comment 15 Bernd Bartmann 2006-01-21 10:38:16 EST
Trying all install ALL packages (even all language options) results in an
installer crash. I've opened up a new bug #178538 on this issue.
Comment 16 Jim Cornette 2006-01-26 06:51:17 EST
Joining this bug and adding comment regarding mozilla suite, xscreensaver-base,
drivers and fonts for X11. These items should be selectable but are not through
the present installer.
The list in comment #11 seems to catch the programs that I could not select.
Adding to CC:
Comment 17 Bernd Bartmann 2006-02-20 15:41:33 EST
Still 759 packages in FC5T3 that are on he CDs but are not getting installed
although all package categories and sub-options have been selected.
Comment 18 Bernd Bartmann 2006-02-20 15:43:45 EST
Created attachment 124907 [details]
list of rpms that are on the FC5T3 install CDs but did not get installed although "everything" install was selected
Comment 19 Marius Andreiana 2006-02-20 16:57:53 EST
A few of them could easily go to Extras (emacs, tcl, tk, xisdnload...). 

Most of the rest are development packages, are the devel categories gone from
anaconda? Or should a catogory like "Software development" install all devel
versions for already selected packages?
Comment 20 Jeremy Katz 2006-03-01 15:02:11 EST
Okay, I just did an install with today's rawhide selecting every group and all
optional packages in all groups (that was fun :-)

I've gone through the list of ~ 650 packages and added things which make sense
to be user visible to the comps file.  There are some things left which should
probably go to Extras after FC5 is released as well as a pile of -devel packages
which aren't generally useful except for building one or two things and so will
get installed for use if you do an rpmbuild.

Note You need to log in before you can comment on or make changes to this bug.