Bug 174246 - frysk causes ldconfig warnings
frysk causes ldconfig warnings
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: frysk (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Cagney
:
: 176322 (view as bug list)
Depends On: 175299
Blocks: 173278
  Show dependency treegraph
 
Reported: 2005-11-26 08:11 EST by Ivan Gyurdiev
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-22 16:55:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Sourceware 1959 None None None Never

  None (edit)
Description Ivan Gyurdiev 2005-11-26 08:11:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
/sbin/ldconfig: Can't link /usr/lib/EggTrayIcon/libEggTrayIcon.so to libEggTrayIcon.so

... * every package that runs /sbin/ldconfig - gets rather annoying.

[root@cobra phantom]# strings /usr/lib/libEgg* |grep EggTrayIcon
Java_frysk_gui_monitor_EggTrayIcon_egg_1tray_1icon_1get_1type
Java_frysk_gui_monitor_EggTrayIcon_egg_1tray_1icon_1new_1for_1screen
Java_frysk_gui_monitor_EggTrayIcon_egg_1tray_1icon_1new
Java_frysk_gui_monitor_EggTrayIcon_egg_1tray_1icon_1send_1message
Java_frysk_gui_monitor_EggTrayIcon_egg_1tray_1icon_1cancel_1message
Java_frysk_gui_monitor_EggTrayIcon_egg_1tray_1icon_1get_1orientation
EggTrayIcon/libEggTrayIcon.so
EggTrayIcon
EggTrayIcon/eggtrayicon.c:141
EggTrayIcon/eggtrayicon.c
[root@cobra phantom]# rpm -qf /usr/lib/libEgg*
frysk-0.0.0.20051116-0.5


Version-Release number of selected component (if applicable):
frysk-0.0.0.20051116-0.5

How reproducible:
Always

Steps to Reproduce:
1. Run /sbin/ldconfig

  

Additional info:
Comment 1 Andrew Cagney 2005-12-01 10:30:16 EST
http://sourceware.org/bugzilla/show_bug.cgi?id=1959
Adding upstream/downstream links.

Will be fixed as part of RHEL-4 RPM.
Comment 2 Andrew Cagney 2005-12-08 13:47:51 EST
Index: frysk-imports/common/ChangeLog
2005-12-08  Andrew Cagney  <cagney@redhat.com>

        * Makefile.rules (.a.so): Fix --soname parameter, strip out any
        directory prefix.
Comment 3 Andrew Cagney 2005-12-08 14:38:41 EST
Currently can't rebuild in rawhide, waiting on 4.1 compiler, and then on getting
build problems resolved.
Comment 4 Andrew Cagney 2005-12-21 09:43:26 EST
*** Bug 176322 has been marked as a duplicate of this bug. ***
Comment 5 Andrew Cagney 2005-12-22 16:55:33 EST
Fixed with frysk-0.0.1.2005.12.14.15.12-0.FC4.1.i386.rpm

Note You need to log in before you can comment on or make changes to this bug.