Bug 174273 - "Upgrade existing install" option not present
"Upgrade existing install" option not present
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
: 174326 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-26 20:50 EST by david.hagood
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-15 15:15:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description david.hagood 2005-11-26 20:50:19 EST
Description of problem:
There is no option to just upgrade a system without reformatting the system!

As it stands now, you get a choice of:

1) Destroy all partitions and install default layout.
2) Destroy all partitions but keep layout.
3) Destroy all partitions and use custom layout.
4) Don't destroy partitions, but then rather than figuring out how they are
mounted, force the user to re-enter the partition layout, and then bitch about
the fact that the partition sizes are somehow "incorrect" even though they are
perfectly fine for the currently installed system.



Version-Release number of selected component (if applicable):
FC5-test 1

How reproducible:
Every time.

Steps to Reproduce:
1. Take my server down
2. Boot from FC5 disk 1
  
Actual results:
Anaconda wants to destroy all my data.

Expected results:
Anaconda should figure out that there is an existing Fedora install and offer to
upgrade it.

Additional info:
Comment 1 Jeremy Katz 2005-11-26 22:17:45 EST
Yes, the fact that upgrades aren't currently working was mentioned right up
front in the release announcement.
Comment 2 Jeremy Katz 2005-11-27 20:24:58 EST
*** Bug 174326 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.