Bug 174274 - Kernel panic - not syncing spin_lock on boot
Kernel panic - not syncing spin_lock on boot
Status: CLOSED DUPLICATE of bug 169613
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-26 21:05 EST by Tim Charman
Modified: 2015-01-04 17:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-10 01:16:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Charman 2005-11-26 21:05:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
On boot, right after uncompressing linux, get the following:

kernel panic - not syncing: drivers/ide/pci/piix.c:232: spin_lock (drivers/ide/ide.c:c03eb708) already locked by drivers/ide/ide-iops.c/1235 (not tainted)
BUG: soft lockup detected on CPU#0!

The boot then hangs.  Work around: set ide=nodma in the boot string, but most things appear slow with this setting.  Makes system almost unusable.

IDE devices - 1x160Gb ATA HD with boot block & Windows, 1x80Gb ATA HD with Linux (FC4, kernel version 2.6.11-1.1369_FC4), 1xCDRW, 1xDVDRW.  Made sure to try booting with nothing in CDRW and DVDRW.  Same error each time tried (about 6 times) without the ide=nodma setting.

Version-Release number of selected component (if applicable):
2.6.11-1.1369_FC4

How reproducible:
Always

Steps to Reproduce:
1. Boot
2. Wait (not very long)

  

Additional info:
Comment 1 Dave Jones 2005-12-10 01:16:26 EST
This was fixed in a later update kernel.    If you're seeing this during the
installation, there's not a workaround for this problem.

The bug I'm duping this against has pointers to an unofficial FC4.2 which has
this fixed. If for some reason you can't get that to work, FC5test1 is your best
bet.


*** This bug has been marked as a duplicate of 169613 ***

Note You need to log in before you can comment on or make changes to this bug.