Bug 1743005 - after upgrade gnome-shell from 3.33.2-1.fc31 to 3.33.3-1.fc31 stop working layout switching in X session
Summary: after upgrade gnome-shell from 3.33.2-1.fc31 to 3.33.3-1.fc31 stop working la...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker AcceptedFreezeExcepti...
Depends On:
Blocks: F31BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2019-08-18 12:37 UTC by Mikhail
Modified: 2019-10-31 14:37 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-31 14:37:53 UTC
Type: Bug


Attachments (Terms of Use)
additional layout options screenshot (117.35 KB, image/png)
2019-08-18 12:37 UTC, Mikhail
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME/gnome-shell/issues/1630 0 None None None 2019-09-17 04:02:49 UTC

Description Mikhail 2019-08-18 12:37:41 UTC
Created attachment 1605449 [details]
additional layout options screenshot

Description of problem:
after upgrade gnome-shell from 3.33.2-1.fc31 to 3.33.3-1.fc31 stop working:
1) layout switching in X session
2) Num Lock switching not synchronized in Wayland session

Version-Release number of selected component (if applicable):
Last working version: 3.33.2-1.fc31
First broken version: 3.33.3-1.fc31

Steps to Reproduce:
1)
- install secondary layout
- install gnome-tweaks
- set additional layout options for switching to another layout for "Ctrl+Shift" combination or "Caps Lock"
- log in X session
- try switching between layouts by "Ctrl+Shift" combination or "Caps Lock"

2)
- log in Wayland session
- make sure that by default "Num Lock" LED is light
- try enter number in gnome-terminal on the numeric keypad

Actual results:
1) layout not switched by "Ctrl+Shift" combination or "Caps Lock"
2) numbers not printed in the terminal

Expected results:
1) layout switched by "Ctrl+Shift" combination or "Caps Lock"
2) numbers printed in the terminal

Comment 1 Fedora Blocker Bugs Application 2019-08-18 12:42:39 UTC
Proposed as a Blocker and Freeze Exception for 31-beta by Fedora user mikhail using the blocker tracking app because:

 Added to blocker because this is a very annoying bug for users who use several layouts.
The default gnome combination "Super+Space" is not comfortable for users who use additional layout options for switching to another layout. 
For me new version of gnome-shell unusable because I need frequently switching between several layouts.

Comment 2 Geoffrey Marr 2019-08-26 15:58:54 UTC
-1 blocker because AFAICS this does not violate any blocker criteria.

Comment 3 Geoffrey Marr 2019-08-26 16:09:50 UTC
Is this a new "feature", i.e. in the changeset from 2-1 to 3-1?

Comment 4 Geoffrey Marr 2019-08-26 18:10:51 UTC
Discussed during the 2019-08-26 blocker review meeting: [1]

The decision to classify this bug as a "RejectedBlocker" and an "AcceptedFreezeException" was made as we find that these issues do not violate the criteria. We tested in-meeting that configuring the layout switch key combo via the Control Center works in both Wayland and X11. FE is granted to any confirmed layout switching config issue with tweak-tool.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2019-08-26/f31-blocker-review.2019-08-26-16.00.txt

Comment 5 Adam Williamson 2019-09-16 18:43:28 UTC
Is this still broken in 3.34 (now in updates-testing)? Has anyone reported it upstream yet?

Comment 6 Mikhail 2019-09-17 04:03:33 UTC
(In reply to Adam Williamson from comment #5)
> Is this still broken in 3.34 (now in updates-testing)?
yes

Comment 7 Hedayat Vatankhah 2019-09-21 14:28:54 UTC
For me, Alt+Shift switching doesn't work. But "CapsLock while pressed" works. Really annoying.

Comment 8 Adam Williamson 2019-09-23 17:18:25 UTC
So, this bug came up today:

https://bugzilla.redhat.com/show_bug.cgi?id=1754373

and I'm wondering if this might actually be related. Are the affected shortcuts ones that use keys that are in different positions on the different layouts?

Comment 9 Artem 2019-09-24 07:25:39 UTC
Workaround: restart gnome-shell by pressing:

Alt+F2
r
Hit Enter

Comment 10 Hedayat Vatankhah 2019-09-24 11:02:39 UTC
(In reply to Artem from comment #9)
> Workaround: restart gnome-shell by pressing:
> 
> Alt+F2
> r
> Hit Enter

Yeah! I just discovered it and was going to post it here (was not 100% sure though) and saw that you've said too. I confirm the workaround works!

Comment 11 Adam Williamson 2019-10-29 00:23:36 UTC
Can anyone confirm whether this bug is still present in F31 as it will be released - https://kojipkgs.fedoraproject.org/compose/31/Fedora-31-20191023.0/ ? Thanks!

Comment 12 Hedayat Vatankhah 2019-10-31 07:09:30 UTC
I tested at least once with latest updates in F31 Beta, and it didn't happen. I'll try more and let you know if problem persists.

Comment 13 Mikhail 2019-10-31 07:14:30 UTC
On Rawhide bug is not produced anymore.

Comment 14 Adam Williamson 2019-10-31 14:37:53 UTC
OK, thanks. Rawhide is not really ahead of F31 ATM, AFAIK, so let's figure this is fixed.


Note You need to log in before you can comment on or make changes to this bug.