Bug 1754373 - Keyboard shortcuts NOT mapped to keyboard layouts
Summary: Keyboard shortcuts NOT mapped to keyboard layouts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F31FinalBlocker, FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2019-09-23 05:59 UTC by Jonathan Haas
Modified: 2019-10-10 19:04 UTC (History)
13 users (show)

Fixed In Version: mutter-3.34.1-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-10 18:26:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Gitlab GNOME/mutter/issues/822 None None None 2019-09-23 05:59:15 UTC

Description Jonathan Haas 2019-09-23 05:59:16 UTC
Let's assume that you have a physical AZERTY keyboard.
On Gnome Shell v.3.34.0, go to Settings > Regions & Languages, in Input Sources, set as default keyboard layout French(alt.) (AZERTY).

Scenario 1
Press <Super>+<A> (on a physical AZERTY keyboard).

Result
Nothing happen.

Expected Result
Expecting to get the Application Overview.

Scenario 2
Press <Super>+<Q> (on a physical AZERTY keyboard).

Result
Opens the Application Overview.

Expected Result
Expecting nothing to happen.

Complementary Information
This issues is reproducible for any keyboard shortcut's entry settable via Settings > Devices > Keyboard Shortcuts.

Comment 1 Fedora Blocker Bugs Application 2019-09-23 06:01:26 UTC
Proposed as a Blocker for 31-final by Fedora user jonha using the blocker tracking app because:

 If a particular keyboard layout has been configured for the system, that keyboard layout must be used [...] for the case of global keyboard shortcuts

Comment 2 Matthias Clasen 2019-09-23 17:04:35 UTC
Is this on Xorg, or Wayland ?

Comment 3 Geoffrey Marr 2019-09-23 18:00:47 UTC
Discussed during the 2019-09-23 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedBlocker" was made as it violates the 'keyboard layout' criterion:

"If a particular keyboard layout has been configured for the system, that keyboard layout must be used...After logging in to a release-blocking desktop, if the user account does not have its own keyboard layout configuration for that desktop (if there is such a user/desktop-specific configuration, it must be used when that user logs in to that desktop)" (for the case of global keyboard shortcuts).

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2019-09-23/f31-blocker-review.2019-09-23-16.03.txt

Comment 4 Jonathan Haas 2019-09-23 18:13:32 UTC
(In reply to Matthias Clasen from comment #2)
> Is this on Xorg, or Wayland ?

From what I can see, Xorg only.

Also sorry for the confusing Blocker proposal, there was originally a newline after the [...], the blocker tracking app must have removed that.

Comment 5 Adam Williamson 2019-09-23 23:43:05 UTC
Hum, we *may* reconsider it for blocker on that basis, though since we do still have various automatic fallbacks to X, maybe it would still qualify.

Note, I rather suspect this and https://bugzilla.redhat.com/show_bug.cgi?id=1743005 are related or the same bug.

Comment 6 Jonathan Haas 2019-09-24 07:19:29 UTC
I know it's not blocker relevant, but I can't use Wayland because of https://gitlab.gnome.org/GNOME/mutter/issues/819.

So it's either keyboard shortcuts broken on Xorg or keyboard stopping to work randomly on Wayland.

Comment 7 Michael Catanzaro 2019-09-25 20:42:11 UTC
I can reproduce this in Wayland. All shell keyboard shortcuts are broken, except for those where the keys happen to be in the same position in both my keyboard layout and en_US.

Comment 8 Michael Catanzaro 2019-09-27 18:58:30 UTC
(In reply to Michael Catanzaro from comment #7)
> I can reproduce this in Wayland. All shell keyboard shortcuts are broken,
> except for those where the keys happen to be in the same position in both my
> keyboard layout and en_US.

Today, still Wayland, the bug is gone. All my keyboard shortcuts work fine.

I wasn't drunk two days ago. The bug was real. I'm pinching myself and I do feel pain....

Comment 9 Fedora Update System 2019-10-09 08:34:46 UTC
FEDORA-2019-8f20f9e4e3 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-8f20f9e4e3

Comment 10 Michael Catanzaro 2019-10-09 18:27:00 UTC
(In reply to Michael Catanzaro from comment #8)
> Today, still Wayland, the bug is gone. All my keyboard shortcuts work fine.
> 
> I wasn't drunk two days ago. The bug was real. I'm pinching myself and I do
> feel pain....

Turned out to be a different bug with the same symptoms. Details in mutter#822.

Comment 11 Fedora Update System 2019-10-09 23:05:25 UTC
accerciser-3.34.1-1.fc31, almanah-0.12.0-1.fc31, at-spi2-atk-2.34.1-1.fc31, eog-3.34.1-1.fc31, epiphany-3.34.1-1.fc31, evince-3.34.1-1.fc31, evolution-3.34.1-1.fc31, evolution-data-server-3.34.1-1.fc31, evolution-ews-3.34.1-1.fc31, evolution-mapi-3.34.1-1.fc31, four-in-a-row-3.34.1-1.fc31, gdk-pixbuf2-2.40.0-1.fc31, gdm-3.34.1-1.fc31, geary-3.34.1-2.fc31, gjs-1.58.1-1.fc31, glib-networking-2.62.1-1.fc31, glib2-2.62.1-1.fc31, gnome-2048-3.34.1-1.fc31, gnome-boxes-3.34.1-1.fc31, gnome-builder-3.34.1-1.fc31, gnome-calculator-3.34.1-1.fc31, gnome-calendar-3.34.1-1.fc31, gnome-control-center-3.34.1-3.fc31, gnome-desktop3-3.34.1-1.fc31, gnome-initial-setup-3.34.1-1.fc31, gnome-maps-3.34.1-1.fc31, gnome-session-3.34.1-2.fc31, gnome-shell-3.34.1-1.fc31, gnome-shell-extensions-3.34.1-1.fc31, gnome-software-3.34.1-1.fc31, gnome-taquin-3.34.1-1.fc31, gnome-terminal-3.34.1-1.fc31, gnome-tetravex-3.34.1-1.fc31, gpaste-3.34.1-1.fc31, gtk3-3.24.12-1.fc31, gvfs-1.42.1-1.fc31, iagno-3.34.1-1.fc31, libdazzle-3.34.1-1.fc31, libgweather-3.34.0-1.fc31, librsvg2-2.46.1-1.fc31, libsoup-2.68.2-1.fc31, mutter-3.34.1-1.fc31, nautilus-3.34.1-1.fc31, quadrapassel-3.34.1-1.fc31, simple-scan-3.34.1-1.fc31, sysprof-3.34.1-1.fc31, totem-3.34.1-1.fc31, vala-0.46.3-1.fc31, vte291-0.58.1-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-8f20f9e4e3

Comment 12 Adam Williamson 2019-10-10 17:12:40 UTC
Can someone verify that the update fixes the issue? Thanks!

Comment 13 Fedora Update System 2019-10-10 18:26:59 UTC
accerciser-3.34.1-1.fc31, almanah-0.12.0-1.fc31, at-spi2-atk-2.34.1-1.fc31, eog-3.34.1-1.fc31, epiphany-3.34.1-1.fc31, evince-3.34.1-1.fc31, evolution-3.34.1-1.fc31, evolution-data-server-3.34.1-1.fc31, evolution-ews-3.34.1-1.fc31, evolution-mapi-3.34.1-1.fc31, four-in-a-row-3.34.1-1.fc31, gdk-pixbuf2-2.40.0-1.fc31, gdm-3.34.1-1.fc31, geary-3.34.1-2.fc31, gjs-1.58.1-1.fc31, glib-networking-2.62.1-1.fc31, glib2-2.62.1-1.fc31, gnome-2048-3.34.1-1.fc31, gnome-boxes-3.34.1-1.fc31, gnome-builder-3.34.1-1.fc31, gnome-calculator-3.34.1-1.fc31, gnome-calendar-3.34.1-1.fc31, gnome-control-center-3.34.1-3.fc31, gnome-desktop3-3.34.1-1.fc31, gnome-initial-setup-3.34.1-1.fc31, gnome-maps-3.34.1-1.fc31, gnome-session-3.34.1-2.fc31, gnome-shell-3.34.1-1.fc31, gnome-shell-extensions-3.34.1-1.fc31, gnome-software-3.34.1-1.fc31, gnome-taquin-3.34.1-1.fc31, gnome-terminal-3.34.1-1.fc31, gnome-tetravex-3.34.1-1.fc31, gpaste-3.34.1-1.fc31, gtk3-3.24.12-1.fc31, gvfs-1.42.1-1.fc31, iagno-3.34.1-1.fc31, libdazzle-3.34.1-1.fc31, libgweather-3.34.0-1.fc31, librsvg2-2.46.1-1.fc31, libsoup-2.68.2-1.fc31, mutter-3.34.1-1.fc31, nautilus-3.34.1-1.fc31, quadrapassel-3.34.1-1.fc31, simple-scan-3.34.1-1.fc31, sysprof-3.34.1-1.fc31, totem-3.34.1-1.fc31, vala-0.46.3-1.fc31, vte291-0.58.1-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Jonathan Haas 2019-10-10 19:00:48 UTC
> Can someone verify that the update fixes the issue? Thanks!

The update fixes the issue. After selecting a French keyboard layout, the application overview now opens with Super+Q (as expected on a physical QWERTZ keyboard).

Comment 15 Adam Williamson 2019-10-10 19:04:18 UTC
Thanks a lot for verifying!


Note You need to log in before you can comment on or make changes to this bug.