Bug 174334 - Bad: Installer crashes at disk partition stage
Summary: Bad: Installer crashes at disk partition stage
Status: CLOSED DUPLICATE of bug 170003
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 4
Hardware: powerpc
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-28 03:48 UTC by myles sharma
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 03:17:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description myles sharma 2005-11-28 03:48:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
At the partitioning stage, get following error:

File "/usr/lib/anaconda/gui.py", line 873, in nextClicked
  self.dispatch.gotoNext()
File "/usr/lib/anaconda/dispatch.py", line 174, in gotoNext
  self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
  rc = apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/partitioning.py", line 54, in partitionObjectsInitialize
  partition.selfFromDisk(diskset)
File "/usr/lib/anaconda/partitions.py", line 108, in setFromDisk
  ptype = partedUtils.get_partition_file_system_type(part)
File "/usr/lib/anaconda/partedUtils.py", line 140, in get_partition_file_system_type
  elif (part.get_flag(parted.PARTITION_BOOT) == 1 and
AttributeError. 'NoneType' object has not attribute 'name'

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot with disc 1 of FC4
2.Start anaconda install
3.Choose either automatic or manual partitioning
  

Actual Results:  Unhandled exception has occurred.

Expected Results:  Continue with install

Additional info:

Comment 1 Jeremy Katz 2005-12-01 03:17:08 UTC

*** This bug has been marked as a duplicate of 170003 ***


Note You need to log in before you can comment on or make changes to this bug.