Bug 1743634 - geo-rep: Changelog archive file format is incorrect
Summary: geo-rep: Changelog archive file format is incorrect
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication
Version: rhgs-3.5
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: RHGS 3.5.0
Assignee: Kotresh HR
QA Contact: Kshithij Iyer
URL:
Whiteboard:
Depends On: 1741890 1746140 1764023 1764176
Blocks: 1696809
TreeView+ depends on / blocked
 
Reported: 2019-08-20 10:58 UTC by Kotresh HR
Modified: 2019-10-30 12:23 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1741890
Environment:
Last Closed: 2019-10-30 12:22:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:3249 0 None None None 2019-10-30 12:23:03 UTC

Description Kotresh HR 2019-08-20 10:58:33 UTC
+++ This bug was initially created as a clone of Bug #1741890 +++

Description of problem:

The created changelog archive file didn't have corresponding year
and month. It created as "archive_%Y%m.tar" on python2 only systems.

[root@rhs-gp-srv7 xsync]# ls -l
total 664564
-rw-r--r--. 1 root root 680509440 Aug 15 16:51 archive_%Y%m.tar
[root@rhs-gp-srv7 xsync]#

Version-Release number of selected component (if applicable):
mainline

How reproducible:
Always on python2 only machine (centos7)

Steps to Reproduce:
1. Create geo-rep session on python2 only machine
2. ls -l /var/lib/misc/gluster/gsyncd/<session>/<brick>/.processed/


Actual results:
changelog archive file format is incorrect. Not substituted with corresponding year and month

Expected results:
changelog archive file name should have correct year and month

Additional info:

--- Additional comment from Worker Ant on 2019-08-16 10:59:26 UTC ---

REVIEW: https://review.gluster.org/23248 (geo-rep: Fix the name of changelog archive file) posted (#1) for review on master by Kotresh HR

Comment 11 errata-xmlrpc 2019-10-30 12:22:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:3249


Note You need to log in before you can comment on or make changes to this bug.