Bug 1746140 - geo-rep: Changelog archive file format is incorrect
Summary: geo-rep: Changelog archive file format is incorrect
Keywords:
Status: CLOSED DUPLICATE of bug 1764176
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: 6
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1741890 1764023 1764176
Blocks: 1743634
TreeView+ depends on / blocked
 
Reported: 2019-08-27 18:14 UTC by Kotresh HR
Modified: 2020-01-20 23:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1741890
Environment:
Last Closed: 2020-01-20 23:13:21 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kotresh HR 2019-08-27 18:14:34 UTC
+++ This bug was initially created as a clone of Bug #1741890 +++

Description of problem:

The created changelog archive file didn't have corresponding year
and month. It created as "archive_%Y%m.tar" on python2 only systems.

[root@rhs-gp-srv7 xsync]# ls -l
total 664564
-rw-r--r--. 1 root root 680509440 Aug 15 16:51 archive_%Y%m.tar
[root@rhs-gp-srv7 xsync]#

Version-Release number of selected component (if applicable):
mainline

How reproducible:
Always on python2 only machine (centos7)

Steps to Reproduce:
1. Create geo-rep session on python2 only machine
2. ls -l /var/lib/misc/gluster/gsyncd/<session>/<brick>/.processed/


Actual results:
changelog archive file format is incorrect. Not substituted with corresponding year and month

Expected results:
changelog archive file name should have correct year and month

Additional info:

--- Additional comment from Worker Ant on 2019-08-16 10:59:26 UTC ---

REVIEW: https://review.gluster.org/23248 (geo-rep: Fix the name of changelog archive file) posted (#1) for review on master by Kotresh HR

--- Additional comment from Worker Ant on 2019-08-22 10:03:57 UTC ---

REVIEW: https://review.gluster.org/23248 (geo-rep: Fix the name of changelog archive file) merged (#4) on master by Aravinda VK

Comment 1 Sunny Kumar 2020-01-20 23:13:21 UTC

*** This bug has been marked as a duplicate of bug 1764176 ***


Note You need to log in before you can comment on or make changes to this bug.