Bug 1744216 - "openstack baremetal node trait list <<node_name>>" returns "Requested API version 1.34 is not supported by the server, client, or the requested operation is not supported by the requested version.Supported version range is 1.1 to 1.37"
Summary: "openstack baremetal node trait list <<node_name>>" returns "Requested API ve...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: z9
: 13.0 (Queens)
Assignee: Dmitry Tantsur
QA Contact: mlammon
URL:
Whiteboard:
Depends On:
Blocks: 1715822
TreeView+ depends on / blocked
 
Reported: 2019-08-21 14:46 UTC by Thom Carlin
Modified: 2019-11-07 14:02 UTC (History)
5 users (show)

Fixed In Version: instack-undercloud-8.4.7-14.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-07 14:01:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 680698 None None None 2019-09-06 14:12:51 UTC
Red Hat Product Errata RHBA-2019:3794 None None None 2019-11-07 14:02:01 UTC

Description Thom Carlin 2019-08-21 14:46:05 UTC
Description of problem:

"openstack baremetal node trait list <<node_name>>" returns "Requested API version 1.34 is not supported by the server, client, or the requested operation is not supported by the requested version.Supported version range is 1.1 to 1.37"

Version-Release number of selected component (if applicable):

13-z

How reproducible:

100%

Steps to Reproduce:
1. install undercloud
2. configure a baremetal node
3. openstack baremetal node trait list <<node name>>

Actual results:

Requested API version 1.34 is not supported by the server, client, or the requested operation is not supported by the requested version.Supported version range is 1.1 to 1.37

Expected results:

List of baremetal node traits

Additional info:

Following https://bugzilla.redhat.com/show_bug.cgi?id=1728607#c4, tried:
IRONIC_API_VERSION="1.34" openstack baremetal node trait list <<node name>>
returned same result

So again we have 2 issues:
1) Getting the node trait list
2) Since this is a recurring issue, how reasonable an RFE would it be to add this logic directly into the client?

Comment 1 Julie Pichon 2019-08-30 14:12:58 UTC
$ openstack help baremetal node trait list
[...]
This command is provided by the python-ironicclient plugin.

The "baremetal node trait list" command is provided by the ironic client plugin, adjusting the component accordingly. However, I also noticed the following in the generic help for "openstack":

  --os-baremetal-api-version <baremetal-api-version>
                        Bare metal API version, default="latest" (the maximum
                        version supported by both the client and the server).
                        (Env: OS_BAREMETAL_API_VERSION)

You may want to try again setting up an environment variable with that name, or using the -os-baremetal-api-version flag. I hope that helps.

Comment 2 Thom Carlin 2019-09-03 17:05:30 UTC
Same result:
OS_BAREMETAL_API_VERSION="1.34" openstack baremetal node trait list <<node_name>>
Requested API version 1.34 is not supported by the server, client, or
the requested operation is not supported by the requested
version.Supported version range is 1.1 to 1.37

Comment 3 Dmitry Tantsur 2019-09-05 13:33:38 UTC
Hi,

the error message can be confusing, the actually relevant bit is "the requested operation is not supported by the requested version". Traits were introduced in version 1.37, not 1.34. Ideas for a better wording are welcome.

Comment 4 Thom Carlin 2019-09-05 19:53:46 UTC
if the API logic was included as previously discussed, the error message could be "Requested operation is not supported by RHOSP 13.  It was introduced in RHOSP 14"

Comment 5 Dmitry Tantsur 2019-09-06 13:41:41 UTC
We cannot provide OSP versions in upstream products (nor do we maintain a mapping between products and API versions).

At some point we stopped hardcoding API versions in the rc files, so that they're detected automatically. I'm not sure if it happened in 13 or later though.

Comment 6 Dmitry Tantsur 2019-09-06 14:12:52 UTC
I'm removing OS_BAREMETAL_API_VERSION from stackrc to allow ironicclient to do the magic itself.

Comment 16 Bob Fournier 2019-11-04 18:05:11 UTC
Verified that we are no longer getting the "Requested API version..." error message when running the trait command.

$ openstack baremetal node trait list controller-0

$

Comment 18 errata-xmlrpc 2019-11-07 14:01:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3794


Note You need to log in before you can comment on or make changes to this bug.