Bug 174431 - /etc/init.d/netdump doesn't work with the version of bash in FC5-test1
/etc/init.d/netdump doesn't work with the version of bash in FC5-test1
Status: CLOSED DUPLICATE of bug 202847
Product: Fedora
Classification: Fedora
Component: netdump (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
Depends On:
  Show dependency treegraph
Reported: 2005-11-28 18:16 EST by Russell Coker
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-03-23 09:38:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Fix gateway detection (482 bytes, patch)
2007-03-23 04:33 EDT, Ruben Kerkhof
no flags Details | Diff

  None (edit)
Description Russell Coker 2005-11-28 18:16:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.92 (like Gecko)

Description of problem:
The below patch is needed to make netdump start correctly on a freshly 
installed FC5test1 system.  The variable trc_output only gets the first line 
of the traceroute output and without the grep command I inserted the first 
line of output doesn't have what is needed. 
Not sure if this is a bash bug or a netdump bug. 
--- /etc/init.d/netdump.orig    2005-11-29 09:56:21.000000000 +1100 
+++ /etc/init.d/netdump 2005-11-29 09:56:46.000000000 +1100 
@@ -113,7 +113,7 @@ 
     # IP address only if client and server are on the same subnet 
     # if not, the needed MAC address is that of the gateway; 
     # either way, this will be the first IP address from traceroute 
-    trc_output="$(traceroute -i $DEV -n -m 1 $host_ip 2> /dev/null)" 
+    trc_output="$(traceroute -i $DEV -n -m 1 $host_ip |grep '^ ' 
2> /dev/null)" 
     if [ $? -eq 0 ]; then 
        trc_output="$(echo $trc_output | grep '^1 ' | awk '{print $2}')" 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:

Additional info:
Comment 1 Rahul Sundaram 2006-02-20 06:19:08 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 2 Neil Horman 2006-06-08 08:17:11 EDT
I assume that this was reopened because the issue continues to exist on FC5 GA?
Comment 4 Ruben Kerkhof 2007-03-23 04:33:19 EDT
Created attachment 150736 [details]
Fix gateway detection

This still exists in netdump-0.7.16-5.
Patch attached.
Comment 5 Neil Horman 2007-03-23 09:38:45 EDT
Sorry, this is a dup of bz 202847.  I've had it fixed for some time by replacing
the use of traceroute with the use of the ip utility.  For some reason the
update never got pushed.  I'm pushing it now.for FC-6 now.  You should be able
to use that package on your FC-5 system without any issue.

*** This bug has been marked as a duplicate of 202847 ***

Note You need to log in before you can comment on or make changes to this bug.