Bug 202847 - Client initscript doesn't work for netconsole
Client initscript doesn't work for netconsole
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: netdump (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
:
: 174431 (view as bug list)
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-08-16 15:01 EDT by Bill Nottingham
Modified: 2014-03-16 23:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-02 15:13:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
initscript fixup (588 bytes, patch)
2006-10-02 14:12 EDT, Neil Horman
no flags Details | Diff
patch that makes it start and work for me (1.48 KB, patch)
2006-10-02 14:50 EDT, Bill Nottingham
no flags Details | Diff

  None (edit)
Description Bill Nottingham 2006-08-16 15:01:22 EDT
Description of problem:

Intial problems found:
1) [ "mac_ip" .. on line 130 ... shouldn't that be [ "$mac_ip" ..
2) still doesn't resolve the address/arp right
3) when I hardcode it in the initscript:
initializing netconsole: netconsole: Unknown parameter 'netlog'

Version-Release number of selected component (if applicable):

netdump-0.7.16-5
Comment 1 Neil Horman 2006-10-02 14:10:50 EDT
the mac_ip line should definately have a $ in front of it, and there also needs
to be an extra equals sign.  Thats fixed in release -6.  As for your other
problems, those sounds like they might be config related.  Please give the
attached patch a try and see if it fixes your problem.  If not, please reply
with your netdump setup, as well as a details description of your network
topology (including mac and ip addresses) between your client and server. 

Thank you!
Comment 2 Neil Horman 2006-10-02 14:12:05 EDT
Created attachment 137580 [details]
initscript fixup
Comment 3 Bill Nottingham 2006-10-02 14:48:18 EDT
(Aside from this, the fact is that most of the netdump package is obsolete. :) )

[root@apone ~]# grep -v "^#" /etc/sysconfig/netdump
NETLOGADDR=nostromo.devel.redhat.com
NETLOGPORT=6666
[root@apone ~]# service netdump start
netdump: cannot arp  on eth0
inicializuji netconsole FATAL: Error inserting netconsole
(/lib/modules/2.6.18-1.2708.fc6/kernel/drivers/net/netconsole.ko): Unknown
symbol in module, or unknown parameter (see dmesg)
                                                           [SELHALO]

(ignore the czech)

So, looking some more:
- the parameter to the kernel is netconsole; the script has netlog
- the traceroute awk line is:

    trc_output="$(traceroute -i $DEV -n -m 1 $host_ip 2> /dev/null)"
    if [ $? -eq 0 ]; then
        trc_output="$(echo $trc_output | grep '^1 ' | awk '{print $2}')"

except that the '1' in the traceroute output has a space preceeding it.
Oh, and the whole sequence is probably better replaced with something like:
ip -o route get to $host_ip dev $DEV | awk '{ print $1 }' :)

Patch attached.
Comment 4 Bill Nottingham 2006-10-02 14:50:58 EDT
Created attachment 137585 [details]
patch that makes it start and work for me
Comment 5 Neil Horman 2006-10-02 15:13:56 EDT
bill makes a good point in that FC6 will be using kdump moving forward, but I'll
check this in just to make sure we have the fix in place should we need it.
Comment 6 Neil Horman 2007-03-23 09:39:08 EDT
*** Bug 174431 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2007-03-23 18:18:06 EDT
netdump-0.7.16-13 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.