Bug 174446 - Installer crashes in handleRenderCallback
Installer crashes in handleRenderCallback
Status: CLOSED DUPLICATE of bug 173845
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-28 23:33 EST by Eli Collins
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-30 22:37:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Anaconda install log (479.37 KB, text/plain)
2005-11-28 23:35 EST, Eli Collins
no flags Details

  None (edit)
Description Eli Collins 2005-11-28 23:33:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050920 Firefox/1.0.7

Description of problem:
I'm installing in VMware VM. Anaconda dies when preparing to install packages. Here's the python backtrace:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 1195, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 245, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 924, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 145, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 216, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/backend.py", line 145, in doInstall
    backend.doInstall(intf, id, instPath)
  File "/usr/lib/anaconda/yuminstall.py", line 752, in doInstall
    self.ayum.run(self.instLog, cb, intf)
  File "/usr/lib/anaconda/yuminstall.py", line 363, in run
    self.populateTs(keepold=0)
  File "/usr/lib/anaconda/yuminstall.py", line 431, in populateTs
    for txmbr in self.tsInfo.getMembers():
  File "/usr/lib/anaconda/sortedtransaction.py", line 86, in getMembers
    returnlist.extend(self.pkgdict[key])
KeyError: ('evince', 'i386', '0', '0.4.0', '2')



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from ISO
2. Format disk, 
3. Select devlopement/server packages, install

  

Additional info:

Send mail for the entire anaconda dump.
Comment 1 Eli Collins 2005-11-28 23:35:38 EST
Created attachment 121570 [details]
Anaconda install log
Comment 2 Chris Lumens 2005-11-29 00:01:22 EST
Did you deselect the Office/Productivity package group while leaving GNOME
Desktop Environment selected?  If so, we know about this problem already. 
Package selection still has a lot of work to go before FC5 final.
Comment 3 Eli Collins 2005-11-29 00:16:01 EST
I did. Apologies for the dupe, I missed this issue when searching.
Comment 4 Jeremy Katz 2005-11-30 22:37:32 EST

*** This bug has been marked as a duplicate of 173845 ***

Note You need to log in before you can comment on or make changes to this bug.