Bug 1744690 - [RFE] EPEL8 branch of perl-Plack
Summary: [RFE] EPEL8 branch of perl-Plack
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: perl-Plack
Version: epel8
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Emmanuel Seyman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1744698 1744699 1744707 1744708 1744709 1758485 1761854 1762923 1762927 1769972 1769974 1769995 1769996 1771702 1771703 1771705 1771707 1771711 1771715 1771717 1775926
Blocks: 1768796 1768799
TreeView+ depends on / blocked
 
Reported: 2019-08-22 17:01 UTC by Pat Riehecky
Modified: 2020-01-03 09:05 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-03 09:05:51 UTC


Attachments (Terms of Use)

Description Pat Riehecky 2019-08-22 17:01:09 UTC
Description of problem:

It would be helpful if this module was packaged for EPEL8

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

There are two AppStream modules for perl in RHEL8 right now.  I'm not sure what the EPEL plan is for multi-perl....

Comment 1 Ralf Corsepius 2019-08-24 08:50:55 UTC
I don't use EPEL nor have I ever supported EPEL nor do I plan or intend to support it.

That said, feel free to maintain this package for EPEL yourself.

Comment 2 Denis Fateyev 2019-09-18 21:52:37 UTC
If anyone interested, missing prerequisites for this package in EPEL8:

DEBUG util.py:593:  No matching package to install: '/usr/bin/python'
DEBUG util.py:593:  No matching package to install: '/usr/sbin/lighttpd'
DEBUG util.py:593:  No matching package to install: 'lighttpd-fastcgi'
DEBUG util.py:593:  No matching package to install: 'perl(Apache::LogFormat::Compiler) >= 0.33'
DEBUG util.py:593:  No matching package to install: 'perl(Authen::Simple::Adapter)'
DEBUG util.py:593:  No matching package to install: 'perl(Authen::Simple::Passwd)'
DEBUG util.py:593:  No matching package to install: 'perl(CGI::Compile) >= 0.03'
DEBUG util.py:593:  No matching package to install: 'perl(CGI::Emulate::PSGI) >= 0.10'
DEBUG util.py:593:  No matching package to install: 'perl(Cookie::Baker) >= 0.07'
DEBUG util.py:593:  No matching package to install: 'perl(Devel::StackTrace::AsHTML) >= 0.11'
DEBUG util.py:593:  No matching package to install: 'perl(Devel::StackTrace::WithLexicals) >= 0.8'
DEBUG util.py:593:  No matching package to install: 'perl(FCGI::Client)'
DEBUG util.py:593:  No matching package to install: 'perl(FCGI::ProcManager)'
DEBUG util.py:593:  No matching package to install: 'perl(File::ShareDir::Install) >= 0.06'
DEBUG util.py:593:  No matching package to install: 'perl(Filesys::Notify::Simple)'
DEBUG util.py:593:  No matching package to install: 'perl(HTTP::Entity::Parser) >= 0.17'
DEBUG util.py:593:  No matching package to install: 'perl(HTTP::Request::AsCGI)'
DEBUG util.py:593:  No matching package to install: 'perl(HTTP::Server::Simple::PSGI)'
DEBUG util.py:593:  No matching package to install: 'perl(Hash::MultiValue) >= 0.05'
DEBUG util.py:593:  No matching package to install: 'perl(IO::Handle::Util)'
DEBUG util.py:593:  No matching package to install: 'perl(LWP::Protocol::http10)'
DEBUG util.py:593:  No matching package to install: 'perl(Log::Dispatch::Array) >= 1.001'
DEBUG util.py:593:  No matching package to install: 'perl(Log::Log4perl)'
DEBUG util.py:593:  No matching package to install: 'perl(Module::Refresh)'
DEBUG util.py:593:  No matching package to install: 'perl(Stream::Buffered) >= 0.02'
DEBUG util.py:593:  No matching package to install: 'perl(Test::TCP) >= 2.15'
DEBUG util.py:593:  No matching package to install: 'perl(WWW::Form::UrlEncoded) >= 0.23'

Comment 3 Emmanuel Seyman 2019-10-16 18:51:22 UTC
I'll take this off Ralf's hands since he doesn't want to maintain epel branches.

Comment 4 Xavier Bachelot 2019-11-12 11:14:55 UTC
The following missing dependencies neither have a bug filed nor a build done:
perl-Cookie-Baker
perl-Devel-StackTrace-AsHTML 
perl-HTTP-Entity-Parser
perl-HTTP-Server-Simple-PSGI
perl-LWP-Protocol-http10
perl-Stream-Buffered
perl-WWW-Form-UrlEncoded

Emmanuel, do you want me to file bugs for them ?

Comment 5 Emmanuel Seyman 2019-11-12 11:39:32 UTC
(In reply to Xavier Bachelot from comment #4)
>
> Emmanuel, do you want me to file bugs for them ?

No, I'll do this tonight.

Comment 6 Xavier Bachelot 2019-11-12 21:35:18 UTC
(In reply to Emmanuel Seyman from comment #5)
> (In reply to Xavier Bachelot from comment #4)
> >
> > Emmanuel, do you want me to file bugs for them ?
> 
> No, I'll do this tonight.

Sorry, I didn't realize the missing deps were all yours.

Comment 7 Emmanuel Seyman 2019-11-13 07:05:52 UTC
(In reply to Xavier Bachelot from comment #6)
> 
> Sorry, I didn't realize the missing deps were all yours.

Actually, they're Ralf's, not mine. But since Ralf doesn't like being assigned EPEL bugs, I decided to file the bugs so that I could assign them to myself, not to him.

But, because requesting a branch doesn't give you commit access to it, I can't push changes. So I've handed over the whole thing to Paul.

Comment 8 Xavier Bachelot 2019-11-27 14:56:26 UTC
lighttpd and lighttpd-fastcgi deps should be ok now. I've added dependencies on their related bugs. (I'm not convinced spawn-fcgi should have been built for EPEL 8 and would have rather argued for it to be retired, but that is a different matter)
/usr/bin/python is thus the only dep that cannot be satisfied. You'll have to choose between /usr/bin/python2 and /usr/bin/python3, with indeed a preference toward the latter.

Comment 9 Xavier Bachelot 2019-11-27 15:19:37 UTC
As python3 is available in all current Fedora releases, EPEL6, EPEL 7 and RHEL/CentOS 8, I would replace :
"""
BuildRequires: /usr/bin/python
"""
by:
"""
BuildRequires: /usr/bin/python3
"""

Hopefully, Ralf would accept such a change to go into master branch.

Comment 10 Emmanuel Seyman 2019-11-27 20:15:29 UTC
(In reply to Xavier Bachelot from comment #8)
> lighttpd and lighttpd-fastcgi deps should be ok now. I've added dependencies
> on their related bugs. (I'm not convinced spawn-fcgi should have been built
> for EPEL 8 and would have rather argued for it to be retired, but that is a
> different matter)

Same here, to be honest. I would have been content to remove the requirement and not do the test but, since lighttpd is availible, I see no reason not to use it.

> /usr/bin/python is thus the only dep that cannot be satisfied. You'll have
> to choose between /usr/bin/python2 and /usr/bin/python3, with indeed a
> preference toward the latter.

That would require back-porting a patch from upstream.[1]
I seem to remember that RHEL 8 had the notion of a system python (regardless of version). If that rings a bell, please speak up. Otherwise, I'll just use what dnf uses.

[1] https://github.com/plack/Plack/pull/639

Comment 11 Xavier Bachelot 2019-11-29 09:51:38 UTC
(In reply to Emmanuel Seyman from comment #10)
> (In reply to Xavier Bachelot from comment #8)
> > lighttpd and lighttpd-fastcgi deps should be ok now. I've added dependencies
> > on their related bugs. (I'm not convinced spawn-fcgi should have been built
> > for EPEL 8 and would have rather argued for it to be retired, but that is a
> > different matter)
> 
> Same here, to be honest. I would have been content to remove the requirement
> and not do the test but, since lighttpd is availible, I see no reason not to
> use it.
> 
I was refering to spawn-fcgi, not to lighttpd.

> > /usr/bin/python is thus the only dep that cannot be satisfied. You'll have
> > to choose between /usr/bin/python2 and /usr/bin/python3, with indeed a
> > preference toward the latter.
> 
> That would require back-porting a patch from upstream.[1]

Backporting the python3 patch to master makes sense too. Fedora is trying hard to remove python2.

> I seem to remember that RHEL 8 had the notion of a system python (regardless
> of version). If that rings a bell, please speak up. Otherwise, I'll just use
> what dnf uses.
> 
> [1] https://github.com/plack/Plack/pull/639

RHEL8 has platform-python, which is used by core tools like yum/dnf.
This is located at '/usr/libexec/platform-python' but this is python3.6 as well.

I'm not sure it really makes sense to use this instead of system python, because Fedora doesn't have (and will not have ?) a platform-python, so for the sake of keeping the same spec for all branches, I'd go for the "real" python3.

Comment 12 Emmanuel Seyman 2019-11-30 09:29:46 UTC
(In reply to Xavier Bachelot from comment #11)
>
> I was refering to spawn-fcgi, not to lighttpd.

Same issue, TBH.
 
> Backporting the python3 patch to master makes sense too. Fedora is trying
> hard to remove python2.

Historically, Ralf does not appreciate other people committing in the master branch of his packages. I'll probably submit a pull-request to him.

> because Fedora doesn't have (and will not have ?) a platform-python, so for
> the sake of keeping the same spec for all branches, I'd go for the "real"
> python3.

Given that the branches do not have the same maintainers, I don't see how we could have the same spec for all branches without a huge amount of work.

Comment 13 Fedora Update System 2019-12-05 20:50:56 UTC
FEDORA-EPEL-2019-5d2caf321b has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-5d2caf321b

Comment 14 Fedora Update System 2019-12-07 03:04:15 UTC
perl-Plack-1.0047-7.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-5d2caf321b

Comment 15 Denis Fateyev 2020-01-03 08:49:36 UTC
Are these packages still on QA?

Comment 16 Petr Pisar 2020-01-03 09:05:51 UTC
Bodhi probably forgets closing bugs.


Note You need to log in before you can comment on or make changes to this bug.