Bug 1744700 - [RFE] EPEL8 branch perl-Authen-Passphrase
Summary: [RFE] EPEL8 branch perl-Authen-Passphrase
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: perl-Authen-Passphrase
Version: epel8
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Robert-André Mauchin 🐧
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1778465 1778466 1778467 1778468
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-22 17:19 UTC by Pat Riehecky
Modified: 2020-01-04 20:07 UTC (History)
2 users (show)

Fixed In Version: perl-Authen-Passphrase-0.008-2.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-04 20:07:44 UTC
Type: Bug


Attachments (Terms of Use)

Description Pat Riehecky 2019-08-22 17:19:38 UTC
Description of problem:

It would be helpful if this module was packaged for EPEL8

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

There are two AppStream modules for perl in RHEL8 right now.  I'm not sure what the EPEL plan is for multi-perl....

Comment 1 Paul Howarth 2019-10-24 13:48:34 UTC
No matching package to install: 'perl(Authen::DecHpwd) >= 2.003'
No matching package to install: 'perl(Crypt::MySQL) >= 0.03'
No matching package to install: 'perl(Crypt::UnixCrypt_XS) >= 0.08'
No matching package to install: 'perl(Data::Entropy::Algorithms)'

Packages for these dependencies will need to be requested and built before perl-Authen-Passphrase can be done.

Comment 2 Paul Howarth 2019-10-27 13:36:38 UTC
Hi Robert,

the not-yet in epel8 dependency tree for this package is as follows:

perl-Authen-Passphrase (eclipseo):
Needs:
* perl-Authen-DecHpwd (eclipseo)
  * perl-Data-Integer (eclipseo)
  * perl-Scalar-String (eclipseo)
* perl-Crypt-DES (https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-6afebf6916)
* perl-Crypt-MySQL (eclipseo)
* perl-Crypt-PasswdMD5 (https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-cb72084646)
* perl-Crypt-UnixCrypt_XS (eclipseo)
  * perl-Algorithm-Loops (eclipseo)
* perl-Data-Entropy (eseyman)
  * perl-Crypt-Rijndael (delete)
  * perl-Data-Float (ppisar)
  * perl-HTTP-Lite (eseyman)

If you like, I can take care of your packages and raise the bugs on the others.

Comment 3 Fedora Update System 2019-12-13 15:05:34 UTC
FEDORA-EPEL-2019-40e4870f3c has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-40e4870f3c

Comment 4 Fedora Update System 2019-12-14 01:52:02 UTC
perl-Authen-Passphrase-0.008-2.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-40e4870f3c

Comment 5 Robert-André Mauchin 🐧 2019-12-14 03:46:43 UTC
Thanks a lot Paul!

Comment 6 Paul Howarth 2019-12-14 10:59:47 UTC
(In reply to Robert-André Mauchin from comment #5)
> Thanks a lot Paul!

Nice to be able to help out such a prolific contributor as yourself :-)

Comment 7 Fedora Update System 2020-01-04 20:07:44 UTC
perl-Authen-Passphrase-0.008-2.el8 has been pushed to the Fedora EPEL 8 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.