Bug 1744714 - [RFE] EPEL8 branch of perl-Log-Log4perl
Summary: [RFE] EPEL8 branch of perl-Log-Log4perl
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: perl-Log-Log4perl
Version: epel8
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jitka Plesnikova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1738385 1748037 1748857 1748913 1749413 1749415
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-22 17:34 UTC by Pat Riehecky
Modified: 2019-09-26 00:09 UTC (History)
5 users (show)

Fixed In Version: perl-Log-Log4perl-1.49-9.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-26 00:09:40 UTC
Type: Bug


Attachments (Terms of Use)

Description Pat Riehecky 2019-08-22 17:34:23 UTC
Description of problem:

It would be helpful if this module was packaged for EPEL8

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

There are two AppStream modules for perl in RHEL8 right now.  I'm not sure what the EPEL plan is for multi-perl....

Comment 1 Jitka Plesnikova 2019-09-05 12:43:03 UTC
There are missing following build dependencies in EPEL 8:
perl-Log-Dispatch
perl-Log-Dispatch-FileRotate

and also these packages have to be added to EPEL 8 for building perl-Log-Dispatch:

mod_perl (bug 1738385 for EPEL 8)
perl-MIME-Lite (bug 1748037 for EPEL 8)
perl-Email-Date-Format (bug 1748913 for EPEL 8)
perl-Mail-Sender
perl-Mail-Sendmail
perl-Test-Needs (bug 1748857 for EPEL 8)

Do you need the package for OCS Inventory?

Comment 2 Pat Riehecky 2019-09-05 13:19:13 UTC
I don't believe I need perl-Log-Dispatch for OCS Inventory based on their published requirements:

https://wiki.ocsinventory-ng.org/03.Basic-documentation/Setting-up-a-OCS-Inventory-Server/#requirements

Comment 3 Jitka Plesnikova 2019-09-05 13:47:47 UTC
perl-Log-Dispatch and perl-Log-Dispatch-FileRotate are build dependencies for perl-Log-Log4perl. I don't own the packages.

If you really need perl-Log-Log4perl, I will create BZs for missing build-requires.

Btw. I don't see any requirement for perl-Log-Log4perl on the documentation page. So, I checked the code in github and Log::Log4perl is not used there.

Comment 4 Pat Riehecky 2019-09-05 14:04:40 UTC
I looked around to see my initial filing reason for this request.

I've got an internal perl program using Log::Log4perl that I was planning to port to EL8.

This particular BZ is not related to OCSInventory.

Comment 6 Fedora Update System 2019-09-11 14:09:43 UTC
FEDORA-EPEL-2019-d22ff33984 has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-d22ff33984

Comment 7 Fedora Update System 2019-09-11 19:27:21 UTC
perl-Log-Log4perl-1.49-9.el8 has been pushed to the Fedora EPEL 8 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-d22ff33984

Comment 8 Fedora Update System 2019-09-26 00:09:40 UTC
perl-Log-Log4perl-1.49-9.el8 has been pushed to the Fedora EPEL 8 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.