Bug 174484 - Xnest has incorrect font paths hard coded
Summary: Xnest has incorrect font paths hard coded
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords: Patch
: 174487 174488 174489 (view as bug list)
Depends On:
Blocks: FC5Blocker
TreeView+ depends on / blocked
 
Reported: 2005-11-29 15:15 UTC by kloczek
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixed spec file for xorg-x11-serve (22.72 KB, text/plain)
2005-11-29 15:32 UTC, kloczek
no flags Details
xorg-x11-server-fontspath.patch for fix fontspath in xorg-x11-server (738 bytes, patch)
2005-11-29 15:33 UTC, kloczek
no flags Details | Diff

Description kloczek 2005-11-29 15:15:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051018 Epiphany/1.8.2

Description of problem:
Distributed binaries have incorrect font paths.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
On try tu run Xnest:

$ Xnest -query <host> :<display>

fails with message:

Could not init font path element /usr/lib/X11/fonts/misc/, removing from list!
Could not init font path element /usr/lib/X11/fonts/TTF/, removing from list!
Could not init font path element /usr/lib/X11/fonts/OTF, removing from list!
Could not init font path element /usr/lib/X11/fonts/Type1/, removing from list!
Could not init font path element /usr/lib/X11/fonts/CID/, removing from list!
Could not init font path element /usr/lib/X11/fonts/100dpi/, removing from list!
Could not init font path element /usr/lib/X11/fonts/75dpi/, removing from list!

Fatal server error:
could not open default font 'fixed'



Additional info:

Comment 1 kloczek 2005-11-29 15:32:52 UTC
Created attachment 121586 [details]
Fixed spec file for xorg-x11-serve

1. use autoreconf -f instead "aclocal --force ; automake ; autoconf" amd added
neccessary BuildRequires,
2. added patch xorg-x11-server-fontspath.patch,
3. remove from %files all %dir which are listed in filesystem package,
4. use %{__make} instead make %{?_smp_mflags} which allow in better way use
parallel compile by simple redefine in for example ~/.rpmmacros %{__make}
macro.
5. remove not used cvsdate %define.

Comment 2 kloczek 2005-11-29 15:33:48 UTC
Created attachment 121587 [details]
xorg-x11-server-fontspath.patch for fix fontspath in xorg-x11-server

Comment 3 Mike A. Harris 2005-11-30 00:23:53 UTC
*** Bug 174487 has been marked as a duplicate of this bug. ***

Comment 4 Mike A. Harris 2005-11-30 00:23:53 UTC
*** Bug 174488 has been marked as a duplicate of this bug. ***

Comment 5 Mike A. Harris 2005-11-30 00:24:13 UTC
*** Bug 174489 has been marked as a duplicate of this bug. ***

Comment 6 Mike A. Harris 2006-02-21 10:44:11 UTC
Same issue for Xvfb:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=174507

Comment 7 Mike A. Harris 2006-02-21 14:08:05 UTC
An attempt to reproduce this with FC5test3 seems to show that it has been
fixed upstream already in the X11R7.0 release.  The following seems to confirm
that as well:

# strings /usr/bin/Xnest |grep /usr
/usr/share/X11/xkbX0-config.keyboard
/usr/share/X11/rgb
/usr/share/X11/fonts/misc/,/usr/share/X11/fonts/TTF/,/usr/share/X11/fonts/OTF,/usr/share/X11/fonts/Type1/,/usr/share/X11/fonts/CID/,/usr/share/X11/fonts/100dpi/,/usr/share/X11/fonts/75dpi/
/usr/lib/xserver/SecurityPolicy
/usr/bin
/usr/share/X11/xkb
/usr/adm/X%smsgs

pts/2 mharris@fc4i386:~$ xinit -- /usr/bin/Xnest :2

Could not init font path element /usr/share/X11/fonts/CID/, removing from list!
FreeFontPath: FPE "/usr/share/X11/fonts/misc/" refcount is 2, should be 1; fixing.

waiting for X server to shut down Could not init font path element
/usr/share/X11/fonts/CID/, removing from list!
FreeFontPath: FPE "/usr/share/X11/fonts/misc/" refcount is 2, should be 1; fixing.


(The above warnings printed to stderr by Xnest are unrelated to the report,
 and more or less harmless.)

Setting status to RAWHIDE.


Note You need to log in before you can comment on or make changes to this bug.