Bug 1745930 - [UI] Only the First network is being saved for GCE Compute Profile and Host
Summary: [UI] Only the First network is being saved for GCE Compute Profile and Host
Keywords:
Status: CLOSED DUPLICATE of bug 1731857
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Compute Resources - GCE
Version: 6.6.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: 6.6.0
Assignee: Kavita
QA Contact: Jitendra Yejare
URL:
Whiteboard:
Depends On:
Blocks: 1721890
TreeView+ depends on / blocked
 
Reported: 2019-08-27 09:20 UTC by Jitendra Yejare
Modified: 2019-10-23 09:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-12 18:05:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 27360 Normal Closed On host edit, not showing selected network under virtual machine TAB in case of GCE 2020-04-02 08:48:57 UTC

Description Jitendra Yejare 2019-08-27 09:20:39 UTC
Description of problem:
The first network in networks list is being saved in GCE Compute Profile if I sele

Version-Release number of selected component (if applicable):
Satellite 6.6 snap 7

How reproducible:
Always

Steps to Reproduce:
1. Create GCE Compute Resource, load data from GCE and test connection successfully.
2. Start creating a new compute profile for GCE.
3. While editing compute profile, select any network in the networks list but not the first network in the list.
4. Save the Compute Profile.
4. Reopen the GCE compute profile and check the network selected is still the same.

Actual results:
1. The first network in the networks list is being saved regardless of what has chosen while saving the Compute Profile.

Expected results:
The chosen network in the networks list should be saved in the Compute Profile.

Additional info:

Comment 3 Jitendra Yejare 2019-08-27 09:38:50 UTC
The same issue is also observed for GCE Host form, the 'Virtual Machine' tab shows the first network in the network list. But provisioning has done in the selected network only as selected and as expected.

Comment 4 Bryan Kearney 2019-09-01 22:01:58 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue https://projects.theforeman.org/issues/27360 has been resolved.

Comment 7 Kavita 2019-09-11 11:30:26 UTC
Hello Zach,

Can I mark this BZ as duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1731857 as attached PR is same and it will fix both BZs?
Merge request is already created for BZ-1731857

Comment 8 Zach Huntington-Meath 2019-09-12 18:05:17 UTC

*** This bug has been marked as a duplicate of bug 1731857 ***


Note You need to log in before you can comment on or make changes to this bug.