Bug 1745933 - TypeError: Argument 1 does not allow None as a value
Summary: TypeError: Argument 1 does not allow None as a value
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 31
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vendula Poncova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f345ef3008182089628ad1939c7...
: 1748208 (view as bug list)
Depends On:
Blocks: BetaBlocker, F31BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2019-08-27 09:29 UTC by lnie
Modified: 2019-09-21 00:02 UTC (History)
13 users (show)

Fixed In Version: anaconda-31.22.3-2 anaconda-31.22.3-2.fc31 anaconda-31.22.4-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-06 17:26:03 UTC


Attachments (Terms of Use)
File: anaconda-tb (900.79 KB, text/plain)
2019-08-27 09:32 UTC, lnie
no flags Details
File: anaconda.log (24.59 KB, text/plain)
2019-08-27 09:32 UTC, lnie
no flags Details
File: dbus.log (2.92 KB, text/plain)
2019-08-27 09:32 UTC, lnie
no flags Details
File: environ (638 bytes, text/plain)
2019-08-27 09:32 UTC, lnie
no flags Details
File: lorax-packages.log (25.20 KB, text/plain)
2019-08-27 09:32 UTC, lnie
no flags Details
File: lsblk_output (1.70 KB, text/plain)
2019-08-27 09:32 UTC, lnie
no flags Details
File: nmcli_dev_list (1.60 KB, text/plain)
2019-08-27 09:32 UTC, lnie
no flags Details
File: os_info (691 bytes, text/plain)
2019-08-27 09:32 UTC, lnie
no flags Details
File: program.log (39.00 KB, text/plain)
2019-08-27 09:32 UTC, lnie
no flags Details
File: storage.log (98.16 KB, text/plain)
2019-08-27 09:33 UTC, lnie
no flags Details
File: syslog (256.46 KB, text/plain)
2019-08-27 09:33 UTC, lnie
no flags Details
File: packaging.log (9.04 KB, text/plain)
2019-08-27 09:33 UTC, lnie
no flags Details
anaconda-tb comment16 (986.85 KB, text/plain)
2019-08-30 22:21 UTC, Chris Murphy
no flags Details

Description lnie 2019-08-27 09:29:55 UTC
Version-Release number of selected component:
anaconda-31.22.2

The following was filed automatically by anaconda:
anaconda 31.22.2 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.7/site-packages/pyanaconda/ui/gui/spokes/lib/custom_storage_helpers.py", line 280, in on_add_confirm_clicked
    self._warningLabel.set_text(self._error)
TypeError: Argument 1 does not allow None as a value

Additional info:
addons:         com_redhat_kdump
blivet-gui-utils.log: 
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-dvd-x86_64-31 rd.live.check quiet
dnf.librepo.log: 
executable:     /sbin/anaconda
hashmarkername: anaconda
hawkey.log:     INFO 8月-27 09:27:15 === Started libdnf-0.35.3 ===
kernel:         5.3.0-0.rc5.git0.1.fc31.x86_64
product:        Fedora
release:        Fedora release 31 (Thirty one)
release_type:   pre-release
type:           anaconda
version:        31

Comment 1 lnie 2019-08-27 09:32:29 UTC
Created attachment 1608452 [details]
File: anaconda-tb

Comment 2 lnie 2019-08-27 09:32:34 UTC
Created attachment 1608453 [details]
File: anaconda.log

Comment 3 lnie 2019-08-27 09:32:36 UTC
Created attachment 1608454 [details]
File: dbus.log

Comment 4 lnie 2019-08-27 09:32:38 UTC
Created attachment 1608455 [details]
File: environ

Comment 5 lnie 2019-08-27 09:32:41 UTC
Created attachment 1608456 [details]
File: lorax-packages.log

Comment 6 lnie 2019-08-27 09:32:43 UTC
Created attachment 1608457 [details]
File: lsblk_output

Comment 7 lnie 2019-08-27 09:32:45 UTC
Created attachment 1608458 [details]
File: nmcli_dev_list

Comment 8 lnie 2019-08-27 09:32:46 UTC
Created attachment 1608459 [details]
File: os_info

Comment 9 lnie 2019-08-27 09:32:53 UTC
Created attachment 1608460 [details]
File: program.log

Comment 10 lnie 2019-08-27 09:33:08 UTC
Created attachment 1608461 [details]
File: storage.log

Comment 11 lnie 2019-08-27 09:33:51 UTC
Created attachment 1608462 [details]
File: syslog

Comment 12 lnie 2019-08-27 09:33:54 UTC
Created attachment 1608463 [details]
File: packaging.log

Comment 13 lnie 2019-08-27 12:57:21 UTC
The reproducer is: 

1)boot the Fedora-Server-dvd-x86_64-31-20190820.n.4.iso with Virt-manager 
2)add a / partition manually on the MANUAL PARTITIONING page,
  the installer will crash after you click the "Add Mount Point" button.

Comment 14 Fedora Blocker Bugs Application 2019-08-27 13:06:05 UTC
Proposed as a Blocker for 31-beta by Fedora user lnie using the blocker tracking app because:

 This bug  violates the following criteria:
The installer must be able to create and install to any workable partition layout using any file system and/or container format combination offered in a default installer configuration

Comment 15 Vendula Poncova 2019-08-27 14:52:05 UTC
Fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/2105

Comment 16 Chris Murphy 2019-08-30 22:20:39 UTC
Is the fix for this in 31.22.3-1? I'll attached the tb I'm getting with that version in the same situation.

Comment 17 Chris Murphy 2019-08-30 22:21:39 UTC
Created attachment 1610019 [details]
anaconda-tb comment16

Comment 18 Chris Murphy 2019-08-30 22:29:38 UTC
Fix is not in anaconda-31.22.3-1.fc31, but after applying the patch in pr 2105, I don't run into this.

Comment 19 Geoffrey Marr 2019-09-03 20:58:12 UTC
Discussed during the 2019-09-03 blocker review meeting: [1]

The decision to classify this bug as an "AcceptedBlocker" was made as this appears to break several of the requirements in the Beta "Custom partitioning" criterion. [0]

[0] https://fedoraproject.org/wiki/Fedora_31_Beta_Release_Criteria#Custom_partitioning
[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2019-09-03/f31-blocker-review.2019-09-03-16.01.txt

Comment 20 Vendula Poncova 2019-09-05 14:36:44 UTC
*** Bug 1748208 has been marked as a duplicate of this bug. ***

Comment 21 Fedora Update System 2019-09-05 19:03:16 UTC
FEDORA-2019-d63e1b617d has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-d63e1b617d

Comment 22 Chris Murphy 2019-09-05 22:10:25 UTC
Tested, fixed. Added karma for this update.

Comment 23 Fedora Update System 2019-09-06 00:22:52 UTC
anaconda-31.22.3-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-d63e1b617d

Comment 24 František Zatloukal 2019-09-06 10:31:56 UTC
anaconda-31.22.3-2.fc31 fixed the issue.

Comment 25 Fedora Update System 2019-09-06 17:26:03 UTC
anaconda-31.22.3-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 26 Fedora Update System 2019-09-17 00:37:00 UTC
FEDORA-2019-2cabc3f936 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-2cabc3f936

Comment 27 Fedora Update System 2019-09-18 02:00:01 UTC
anaconda-31.22.4-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-2cabc3f936

Comment 28 Fedora Update System 2019-09-21 00:02:40 UTC
anaconda-31.22.4-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.