Bug 1748208 - Crashes when trying to create partition
Summary: Crashes when trying to create partition
Keywords:
Status: CLOSED DUPLICATE of bug 1745933
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-03 07:37 UTC by Milan Crha
Modified: 2019-09-05 14:36 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-05 14:36:44 UTC


Attachments (Terms of Use)
report.zip (138.02 KB, application/zip)
2019-09-03 07:37 UTC, Milan Crha
no flags Details

Description Milan Crha 2019-09-03 07:37:10 UTC
Created attachment 1611037 [details]
report.zip

Steps:

a) Download Fedora-Workstation-Live-x86_64-Rawhide-20190902.n.0.iso and boot it in a virtual machine which already contains another Fedora.
b) after it boots, click "Install Fedora"
c) pick English/English and "I want to proceed"
d) pick the destination and there "Custom" (not "Advanced Custom (Blivet-GUI)")
e) the LVM is preselected in the combo, left it as is, and delete all existing partitions from the disk
f) then click the "+" and use:
   Mount Point: /
   Desired Capacity: 19.5GB
g) click Add mount point

The anaconda setup crashes. The report it provided is attached (zipped, it's too large). The top of it says:

anaconda 32.3 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.8/site-packages/pyanaconda/ui/gui/spokes/lib/custom_storage_helpers.py", line 280, in on_add_confirm_clicked
    self._warningLabel.set_text(self._error)
TypeError: Argument 1 does not allow None as a value

Local variables in innermost frame:
self: <pyanaconda.ui.gui.spokes.lib.custom_storage_helpers.AddDialog object at 0x7f8a96be1f70>
button: <Gtk.Button object at 0x7f8a9416fd00 (GtkButton at 0x55bbe173ca40)>
args: ()

Comment 1 Vendula Poncova 2019-09-05 14:36:44 UTC

*** This bug has been marked as a duplicate of bug 1745933 ***


Note You need to log in before you can comment on or make changes to this bug.