Bug 174607 - /root created with wrong selinux context
/root created with wrong selinux context
Status: CLOSED DUPLICATE of bug 174227
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-30 12:34 EST by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-30 22:34:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2005-11-30 12:34:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
/root is created as system_u:object_r:default_t, but it needs system_u:object_r:user_home_dir_t to function properly.  Without it, you get errors as follows.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install FC5test1
2.Log in as some regular user
3.Run `su -'

Actual Results:  su: warning: cannot change directory to /root: Permission denied
su: warning: cannot change directory to /root: Permission denied
Yes, twice.

Expected Results:  No such warnings or failures to chdir.

Additional info:

restorecon /root is enough to fix the problem.
Comment 1 Jeremy Katz 2005-11-30 22:34:30 EST

*** This bug has been marked as a duplicate of 174227 ***

Note You need to log in before you can comment on or make changes to this bug.