Bug 174616 - Eclipse does not use native code on x86_64
Eclipse does not use native code on x86_64
Status: CLOSED DUPLICATE of bug 176562
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Depends On:
  Show dependency treegraph
Reported: 2005-11-30 13:38 EST by Robin Green
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-01-05 12:22:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Robin Green 2005-11-30 13:38:31 EST
Description of problem:
Eclipse runs fully interpreted on x86_64.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run eclipse
2. pmap `pidof gij`

Actual results:
No native libraries loaded apart from native libraries

Expected results:
Most of eclipse should be run natively

Additional info:

A clue: gcj-dbtool -p says


which does not exist!

Unfortunately, it's difficult to debug this with strace because doing so crashes
my machine so bad that only hitting the power button will make it wake up (and
shut down) :(
Comment 1 Robin Green 2005-11-30 13:41:31 EST
This fixes the problem:

-Dgnu.gcj.precompiled.db.path=`gcj-dbtool -p /usr/lib64`
Comment 2 Andrew Overholt 2005-12-02 15:48:55 EST
I thought gbenson had made a new java-gcj-compat that took care of different gcj
version numbers.  Gary?
Comment 3 Robin Green 2005-12-03 07:01:58 EST
I don't think it's the gcj version number that's the problem. It's the fact that
the x86_64 build of libgcj is looking in /usr/lib for .db files instead of
Comment 4 Gary Benson 2005-12-05 04:07:56 EST
Certainly older versions of gcj were looking in /usr/lib instead of /usr/lib64,
on all multilib archs.  If it's still happening then you should file a bug
against gcc.
Comment 5 Robin Green 2006-01-05 12:22:00 EST

*** This bug has been marked as a duplicate of 176562 ***

Note You need to log in before you can comment on or make changes to this bug.