This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 176562 - x86-64 gij not using .jar.so files
x86-64 gij not using .jar.so files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: java-1.4.2-gcj-compat (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Fitzsimmons
:
: 174616 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-26 09:06 EST by Anthony Green
Modified: 2013-01-09 22:40 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-27 10:06:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Green 2005-12-26 09:06:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
The x86-64 gij is a 64-bit application.  All .jar files are also built as 64-bit .so files, and we maintain a /usr/lib64/classmap.db file.

However, at runtime, strace tells us that libgcj is trying to read /usr/lib/classmap.db, so no native versions of the .jar files are every used.

Running gij with -Dgnu.gcj.precompiled.db.path=/usr/lib64/gcj-4.1.0/classmap.db shows that .jar.so file execution works, so we just need to either
a) build all java stuff as 32-bit only, or
b) make sure libgcj is pointed at /usr/lib64/gcj-4.1.0/classmap.db


Version-Release number of selected component (if applicable):
libgcj-4.1.0-0.10

How reproducible:
Always

Steps to Reproduce:
1.Run any java program
2.Use lsof to see what files it has open.  You won't see any .jar.so files.
3.
  

Additional info:
Comment 1 Anthony Green 2006-01-03 14:59:12 EST
This appears to be the same as
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=174616
Comment 2 Robin Green 2006-01-05 12:22:24 EST
*** Bug 174616 has been marked as a duplicate of this bug. ***
Comment 3 Jakub Jelinek 2006-01-07 12:15:11 EST
The libgcj side should be fixed in gcc-4.1.0-0.14, please test it out.
Now, /usr/bin/rebuild-gcj-db needs to be fixed to regenerate all multilib
databases.  I'd say just iterating over /usr/lib*/`dirname $(gcj-dbtool -p /)`
would be sufficient.
Comment 4 Anthony Green 2006-01-27 10:06:48 EST
I just did a fresh x86-64 test2 install and yum update.  This appears to be
fixed.  I'm going to close it.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.