Bug 174635 - Saving text files in project fails
Saving text files in project fails
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
:
: 174644 175159 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-30 17:59 EST by Jock Findlay
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-30 21:17:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jock Findlay 2005-11-30 17:59:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Saving text file at first fails with message box: 
´Save Failed: null´. 

Second and subsequent attempts to save result in the message box:
´Save Failed: org.eclipse.core.internal.utils.UniversalUniqueIdentifier´.  

For 2 attempts console gives 
Save Failed
Reason:
Save Failed
Save Failed
Reason:
Save Failed



Version-Release number of selected component (if applicable):
eclipse-platform-3.1.1-1jpp_1fc.FC4.4

How reproducible:
Always

Steps to Reproduce:
1. Start eclipse from menu
2. Open a text file from the project space window
3. Edit the text file
4. Save the text file
  

Actual Results:  Message box:
´Save Failed: null´
File was not saved.

Expected Results:  File saved

Additional info:

# ls -l local.mkf
-rw-r--r--  1 jock jock 454 Nov 30 01:10 local.mkf

# java --version:
java version "1.4.2"
gij (GNU libgcj) version 4.0.2 20051125 (Red Hat 4.0.2-8)

Copyright (C) 2005 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.


From /opt/IBMJava2-amd64-142/bin
# ./java -version
java version "1.4.2"
Java(TM) 2 Runtime Environment, Standard Edition (build 2.2)
IBM J9SE VM (build 2.2, J2RE 1.4.2 IBM J9 2.2 Linux amd64-64 j9xa64142-20050929 (JIT enabled)
J9VM - 20050915_1103_LHdSMr
JIT  - r7_level20050909_1801)
Comment 1 Andrew Overholt 2005-11-30 18:02:03 EST
I can't reproduce on i386.  Are you using our stuff (gcj/gij/libgcj) or the IBM JVM?
Comment 2 Jock Findlay 2005-11-30 20:50:21 EST
I guess I´m using the gcj/gij/libgcj since java is soft linked to
/etc/alternatives/java
which is a soft link to 
/usr/lib/jvm/jre-1.4.2-gcj/bin/java
which is a soft link to 
/usr/bin/gij
(!)

I notice the eclipse website lists the IBM JVM but not the GNU one.  So I´ve
installed the IBM one but obviously it hasn´t replaced the GNU one.  I´m not
overly keen on manually setting all the links and environment variables without
knowing if this is the issue.  Or is changing JVM simpler than that?

This from the error log (found under Help|About|Configuration Details|View Error
Log):

!ENTRY org.eclipse.ui 2 0 2005-11-30 22:07:48.419
!MESSAGE Save Failed
!STACK 0
java.lang.NoClassDefFoundError:
org.eclipse.core.internal.utils.UniversalUniqueIdentifier
   at java.lang.Class.initializeClass() (/usr/lib64/libgcj.so.6.0.0)
...

Can I simply change the JVM in a configuration file?  Which file?
Comment 3 Jock Findlay 2005-11-30 21:17:11 EST
Bingo! As root remove /bin/java and then ´ln -s /opt/IBMJava2-amd64-142/bin/java
/bin/java´
Is so easy :-)
Thanks for the help.
Comment 4 Andrew Overholt 2005-12-02 15:41:29 EST
*** Bug 174644 has been marked as a duplicate of this bug. ***
Comment 5 Andrew Overholt 2005-12-02 15:45:28 EST
The alternatives system is the recommended way of switching between different
JVMs.  This is a good read for working with proprietary JVMs and JPackage:

http://fedoranews.org/mediawiki/index.php/JPackage_Java_for_FC4

Ignore the part about using a 1.5-level JVM.  The procedure can be used for the
IBM JVM as well.  http://jpackage.org might also have some pertinent information.
Comment 6 Andrew Overholt 2005-12-06 20:30:21 EST
*** Bug 175159 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.