Bug 174655 - memory problems with > 2G
Summary: memory problems with > 2G
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 174978 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-12-01 04:21 UTC by John Ellson
Modified: 2015-01-04 22:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-23 17:52:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
picture of panic with kernel-2.6.14-1.1739_FC5 and 4G memory (1.62 MB, image/jpeg)
2005-12-06 00:56 UTC, John Ellson
no flags Details

Description John Ellson 2005-12-01 04:21:27 UTC
Description of problem:
kernel-2.6.14-1.1632_FC5 only see 2.8G when 4G is installed.

Later kernels, including kernel-2.6.14-1.1719_FC5, go into some very early panic
when > 2G installed.

Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1719_FC5
kernel-2.6.14-1.1632_FC5

How reproducible:
100%

Steps to Reproduce:
1. install 4G memory
2. reboot
3.
  
Actual results:


Expected results:
4G real memory should work on a 64bit processor

Additional info:

Comment 1 Dave Jones 2005-12-01 09:48:54 UTC
can you grab the latest kernel from
http://people.redhat.com/davej/kernels/Fedora/devel/ and paste the output of
dmesg -s 128000 please ?

(The panic should be fixed in 1725 and newer)

Comment 2 John Ellson 2005-12-05 13:04:57 UTC
(I hate the way bugs in NEEDINFO state disappear from "My Bugs" in Bugzilla!)

I'm not close to the machine now, but when  retried with 4G yesterday, with 1739
I think, I was still getting panics very early in the reboot sequence.

No opportunity to run dmesg.

I tried with and without the bios option of filling the memory hole.

Comment 3 John Ellson 2005-12-06 00:56:46 UTC
Created attachment 121881 [details]
picture of panic with kernel-2.6.14-1.1739_FC5 and 4G memory

This also with mkinitrd-5.0.10-1 since sofware rid doesn't work with
mkinitrd-5.0.12-1

Comment 4 Tim Waugh 2005-12-06 10:31:12 UTC
*** Bug 174978 has been marked as a duplicate of this bug. ***

Comment 5 Tim Waugh 2005-12-06 10:33:17 UTC
I see this too.  Still happens with 1740 from people.redhat.com.  ASUS SK8N
motherboard, AMIBIOS revision 1004.

Comment 6 Tim Waugh 2006-02-23 17:52:58 UTC
This doesn't seem to happen any more.


Note You need to log in before you can comment on or make changes to this bug.