Bug 1746845 - python-astroscrappy fails to build with Python 3.8 on Fedora 32+
Summary: python-astroscrappy fails to build with Python 3.8 on Fedora 32+
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-astroscrappy
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Christian Dersch
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F32FTBFS F32FailsToInstall PYTEST4 PYTHON38
TreeView+ depends on / blocked
 
Reported: 2019-08-29 11:38 UTC by Miro Hrončok
Modified: 2019-09-11 23:41 UTC (History)
3 users (show)

Fixed In Version: python-astroscrappy-1.0.5-16.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-11 23:41:17 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2019-08-29 11:38:23 UTC
python-astroscrappy fails to build with Python 3.8.0b3 in Fedora 32.

See the build failures at https://koji.fedoraproject.org/koji/search?match=glob&type=package&terms=python-astroscrappy

BUILDSTDERR: Traceback (most recent call last):
BUILDSTDERR:   File "<string>", line 1, in <module>
BUILDSTDERR:   File "/tmp/astroscrappy-test-zsu8w_ej/lib64/python3.8/site-packages/astroscrappy/_astropy_init.py", line 107, in test
BUILDSTDERR:     return test_runner.run_tests(
BUILDSTDERR:   File "/usr/lib64/python3.8/site-packages/astropy/tests/runner.py", line 606, in run_tests
BUILDSTDERR:     return super().run_tests(**kwargs)
BUILDSTDERR:   File "/usr/lib64/python3.8/site-packages/astropy/tests/runner.py", line 243, in run_tests
BUILDSTDERR:     return pytest.main(args=args, plugins=plugins)
BUILDSTDERR:   File "/usr/lib/python3.8/site-packages/_pytest/config/__init__.py", line 63, in main
BUILDSTDERR:     config = _prepareconfig(args, plugins)
BUILDSTDERR:   File "/usr/lib/python3.8/site-packages/_pytest/config/__init__.py", line 206, in _prepareconfig
BUILDSTDERR:     return pluginmanager.hook.pytest_cmdline_parse(
BUILDSTDERR:   File "/usr/lib/python3.8/site-packages/pluggy/hooks.py", line 289, in __call__
BUILDSTDERR:     return self._hookexec(self, self.get_hookimpls(), kwargs)
BUILDSTDERR:   File "/usr/lib/python3.8/site-packages/pluggy/manager.py", line 91, in _hookexec
BUILDSTDERR:     return self._inner_hookexec(hook, methods, kwargs)
BUILDSTDERR:   File "/usr/lib/python3.8/site-packages/pluggy/manager.py", line 82, in <lambda>
BUILDSTDERR:     self._inner_hookexec = lambda hook, methods, kwargs: hook.multicall(
BUILDSTDERR:   File "/usr/lib/python3.8/site-packages/pluggy/callers.py", line 203, in _multicall
BUILDSTDERR:     gen.send(outcome)
BUILDSTDERR:   File "/usr/lib/python3.8/site-packages/_pytest/helpconfig.py", line 94, in pytest_cmdline_parse
BUILDSTDERR:     config = outcome.get_result()
BUILDSTDERR:   File "/usr/lib/python3.8/site-packages/pluggy/callers.py", line 80, in get_result
BUILDSTDERR:     raise ex[1].with_traceback(ex[2])
BUILDSTDERR:   File "/usr/lib/python3.8/site-packages/pluggy/callers.py", line 187, in _multicall
BUILDSTDERR:     res = hook_impl.function(*args)
BUILDSTDERR:   File "/usr/lib/python3.8/site-packages/_pytest/config/__init__.py", line 687, in pytest_cmdline_parse
BUILDSTDERR:     self.parse(args)
BUILDSTDERR:   File "/usr/lib/python3.8/site-packages/_pytest/config/__init__.py", line 895, in parse
BUILDSTDERR:     self._preparse(args, addopts=addopts)
BUILDSTDERR:   File "/usr/lib/python3.8/site-packages/_pytest/config/__init__.py", line 829, in _preparse
BUILDSTDERR:     self._initini(args)
BUILDSTDERR:   File "/usr/lib/python3.8/site-packages/_pytest/config/__init__.py", line 756, in _initini
BUILDSTDERR:     r = determine_setup(
BUILDSTDERR:   File "/usr/lib/python3.8/site-packages/_pytest/config/findpaths.py", line 127, in determine_setup
BUILDSTDERR:     rootdir, inifile, inicfg = getcfg([ancestor], config=config)
BUILDSTDERR:   File "/usr/lib/python3.8/site-packages/_pytest/config/findpaths.py", line 49, in getcfg
BUILDSTDERR:     fail(
BUILDSTDERR:   File "/usr/lib/python3.8/site-packages/_pytest/outcomes.py", line 119, in fail
BUILDSTDERR:     raise Failed(msg=msg, pytrace=pytrace)
BUILDSTDERR: Failed: [pytest] section in setup.cfg files is no longer supported, change to [tool:pytest] instead.
BUILDSTDERR: /usr/lib64/python3.8/distutils/dist.py:274: UserWarning: Unknown distribution option: 'test_requires'
BUILDSTDERR:   warnings.warn(msg)

It is not important whether the problem is relevant to Python 3.8, this issue is blocking the Python 3.8 rebuilds.
If this package won't build with 3.8, it won't be installable, along with all its dependent packages, in Fedora 32 and further.

Furthermore, as it fails to install, its dependent packages will fail to install and/or build as well.

Please rebuild the package in Fedora 32 (rawhide).

Let us know here if you have any questions. Thank You!

Comment 1 Miro Hrončok 2019-08-29 11:40:16 UTC
Trying with:

%prep
...

# Pytest 4 no longer supports plain [pytest]
sed -i 's/\[pytest\]/\[tool:pytest\]/' setup.cfg

Task info: https://koji.fedoraproject.org/koji/taskinfo?taskID=37334510

Comment 2 Miro Hrončok 2019-08-29 11:47:41 UTC
That doesn't help:

Executing(%check): /bin/sh -e /var/tmp/rpm-tmp.perLiU
+ umask 022
+ cd /builddir/build/BUILD
+ cd astroscrappy-1.0.5
+ /usr/bin/python3 setup.py test
BUILDSTDERR: Download error on https://pypi.python.org/simple/astropy-helpers/: [Errno -2] Name or service not known -- Some packages may not be found!
BUILDSTDERR: Download error on https://pypi.python.org/simple/: [Errno -2] Name or service not known -- Some packages may not be found!
running test
installing to temporary directory: /tmp/astroscrappy-test-bltdipqz
BUILDSTDERR: /usr/lib/python3.8/site-packages/pytest_doctestplus/plugin.py:22: SyntaxWarning: invalid escape sequence \.
BUILDSTDERR:   'rst': '\.\.'
BUILDSTDERR: ImportError while loading conftest '/tmp/astroscrappy-test-bltdipqz/lib64/python3.8/site-packages/astroscrappy/conftest.py'.
BUILDSTDERR: astroscrappy/conftest.py:7: in <module>
BUILDSTDERR:     from astropy.tests.pytest_plugins import *
BUILDSTDERR: E   ModuleNotFoundError: No module named 'astropy.tests.pytest_plugins'
BUILDSTDERR: /usr/lib64/python3.8/distutils/dist.py:274: UserWarning: Unknown distribution option: 'test_requires'
BUILDSTDERR:   warnings.warn(msg)
BUILDSTDERR: error: Bad exit status from /var/tmp/rpm-tmp.perLiU (%check)
RPM build errors:
BUILDSTDERR:     Bad exit status from /var/tmp/rpm-tmp.perLiU (%check)

Comment 3 Mamoru TASAKA 2019-09-11 23:41:17 UTC
Add a patch with referring to https://github.com/spacetelescope/poppy/issues/289
Once fixed in python-astroscrappy-1.0.5-16.fc32


Note You need to log in before you can comment on or make changes to this bug.