Bug 174711 - vnc-server-4.1.1-24 coredumping on startup
vnc-server-4.1.1-24 coredumping on startup
Status: CLOSED DUPLICATE of bug 173323
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-01 12:04 EST by Jonathan Kamens
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 12:09:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2005-12-01 12:04:17 EST
I know there's another ticket which says this is supposed to work now, but 
it's coredumping for me.  Here's what shows up in the log file:

Xvnc Free Edition 4.1.1
Copyright (C) 2002-2005 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
Underlying X server release 69999902, The X.Org Foundation

Could not init font path element /usr/share/X11/fonts/OTF, removing from list!
Could not init font path element /usr/share/X11/fonts/Type1/, removing from 
list!
Could not init font path element /usr/share/X11/fonts/CID/, removing from list!
X connection to :2.0 broken (explicit kill or server shutdown).^M
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":2.0"^M
      after 7 requests (6 known processed) with 0 events remaining.^M

and here's what shows up in the stack trace:

(gdb) where
#0  0x080e8804 in XkbCFFreeRtrn ()
#1  0x08064d95 in dixDestroyPixmap ()
#2  0x08066f9a in dixDestroyPixmap ()
#3  0x08077898 in ReplyNotSwappd ()
#4  0x004b862f in __libc_start_main () from /lib/libc.so.6
#5  0x08056511 in ?? ()

I dont' see a debuginfo package, so I can't get more specific than this.

  jik
Comment 1 Tim Waugh 2005-12-01 12:09:33 EST
The fixed version is 4.1.1-25, which is still building and will hopefully show
up in tomorrow's tree.

(Or, you can check it out from CVS and build from there.)

*** This bug has been marked as a duplicate of 173323 ***

Note You need to log in before you can comment on or make changes to this bug.