Bug 173323 - Re-base vnc on modular xorg-x11
Re-base vnc on modular xorg-x11
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
: 174382 174711 (view as bug list)
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-11-16 05:47 EST by Tim Waugh
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: 4.1.1-25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-04 05:56:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2005-11-16 05:47:34 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthias Saou 2005-11-18 07:46:23 EST
With modular X, could including Source2 be avoided?
It adds 42.6M to the source rpm...

Other than that, seems like simply replacing :

ext=%{buildroot}/usr/X11R6/%{_lib}/modules/extensions

with a nice "pkg-config xorg-server" call to the the extensions path could
be enough to fix the package for now.
Comment 2 Tim Waugh 2005-11-28 13:03:08 EST
*** Bug 174382 has been marked as a duplicate of this bug. ***
Comment 3 Charles Lopes 2005-11-28 13:15:20 EST
So this will also fix the issue reported in #174382 with the hardcoded path to
SecurityPolicy on FC4 with non-modular X?
Comment 4 Tim Waugh 2005-11-28 13:23:51 EST
That's why I marked it as a duplicate, yes.
Comment 5 Tim Waugh 2005-11-29 17:57:57 EST
4.1.1-23 has a first attempt.  Only the xorg-x11-server package needs bundling,
which reduces the source RPM size by quite a lot.  Unfortunately, the Xvnc
program needs an X server tree to build in -- the SDK is not sufficient.

I haven't tried to get the extension module built yet, just the Xvnc binary.
Comment 6 Tim Waugh 2005-12-01 04:52:12 EST
Okay, extension module built too.
Comment 7 Tim Waugh 2005-12-01 04:56:16 EST
..except the Xvnc binary crashes as soon as you connect.  Joy.
Comment 8 Tim Waugh 2005-12-01 10:15:52 EST
Okay, now it works and everything.
Comment 9 Tim Waugh 2005-12-01 11:12:10 EST
*** Bug 174702 has been marked as a duplicate of this bug. ***
Comment 10 Tim Waugh 2005-12-01 12:09:40 EST
*** Bug 174711 has been marked as a duplicate of this bug. ***
Comment 11 Alexandre Oliva 2005-12-03 20:43:13 EST
Doesn't work on x86_64.  Having `Load "vnc"' in xorg.conf causes X to not
display anything at all on the screen.  Commenting that line out, it gets back
to work.  On i386, this works just fine.  This worked up to -22, I believe,
although I think I still needed a symlink in the new extensiosn dir to point to
the old one.
Comment 12 Tim Waugh 2005-12-04 05:56:43 EST
The x86_64 problem is a separate bug report now: bug #174702.

Note You need to log in before you can comment on or make changes to this bug.