Bug 1747186 - [VMware] Publish to template operation fails with error "Error: [EVM] VM [template-test] Step [EmailOwner] Status [Error Emailing Owner]"
Summary: [VMware] Publish to template operation fails with error "Error: [EVM] VM [tem...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.10.9
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.10.11
Assignee: Tina Fitzgerald
QA Contact: Kedar Kulkarni
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On: 1698542
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-29 20:45 UTC by Kedar Kulkarni
Modified: 2019-10-09 13:51 UTC (History)
11 users (show)

Fixed In Version: 5.10.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-09 13:51:12 UTC
Category: Bug
Cloudforms Team: VMware
Target Upstream Version:
kkulkarn: automate_bug+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2967 None None None 2019-10-09 13:51:26 UTC

Description Kedar Kulkarni 2019-08-29 20:45:05 UTC
Description of problem:
Publish to Template process fails with error 'Error: [EVM] VM [template-test] Step [EmailOwner] Status [Error Emailing Owner]' 
This happens on fresh appliances where I haven't touched anything related to email in config. So there is no user error surrounding email. 



Version-Release number of selected component (if applicable):
5.10.9.1

How reproducible:
100%

Steps to Reproduce:
1.Add VMware provider
2.Select any VM
3.Lifecycle-> publish to template

Actual results:
Request fails with error Emailing Owner

Expected results:
Request should succeed

Additional info:

Seems like this was never backported, fixed in the 5.11, under this BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1698542
and my BZ https://bugzilla.redhat.com/show_bug.cgi?id=1703592 was closed duplicate.

Comment 4 Kedar Kulkarni 2019-09-09 22:14:16 UTC
Hello, This bug is also present in 5.10.10.0.

Comment 7 CFME Bot 2019-09-19 20:36:16 UTC
New commit detected on ManageIQ/manageiq-content/hammer:

https://github.com/ManageIQ/manageiq-content/commit/2362c535bd1b293bcf8885f9fd2a3184f0d3062a
commit 2362c535bd1b293bcf8885f9fd2a3184f0d3062a
Author:     tina <tfitzger@redhat.com>
AuthorDate: Fri May 10 14:10:43 2019 -0400
Commit:     tina <tfitzger@redhat.com>
CommitDate: Fri May 10 14:10:43 2019 -0400

    Merge pull request #529 from billfitzgerald0120/email_infra_template_complete2

    Create Publish to Template email instance and method.

    (cherry picked from commit b7bd3166ef3678d49b443298ff14d3e14c9bfb35)

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1747186

 content/automate/ManageIQ/Infrastructure/VM/Provisioning/StateMachines/VMProvision_Template.class/__class__.yaml | 2 +-
 content/automate/ManageIQ/System/Notification/Email.class/__methods__/miq_provision_template_customize_body.rb | 69 +
 content/automate/ManageIQ/System/Notification/Email.class/__methods__/miq_provision_template_customize_body.yaml | 12 +
 content/automate/ManageIQ/System/Notification/Email.class/infrastructuremiqprovisiontemplatecomplete.yaml | 18 +
 spec/content/automate/ManageIQ/System/Notification/Email.class/__methods__/miq_provision_template_customize_body_spec.rb | 108 +
 5 files changed, 208 insertions(+), 1 deletion(-)

Comment 8 Kedar Kulkarni 2019-09-26 17:01:43 UTC
This error no longer exists in build 5.10.11.0

Comment 10 errata-xmlrpc 2019-10-09 13:51:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2967


Note You need to log in before you can comment on or make changes to this bug.