Bug 174730 - emacs-21.4-10 coredumps if you try to kill a modified buffer
emacs-21.4-10 coredumps if you try to kill a modified buffer
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
: 174899 (view as bug list)
Depends On:
Blocks: 499035
  Show dependency treegraph
 
Reported: 2005-12-01 14:07 EST by Jonathan Kamens
Modified: 2009-05-04 17:14 EDT (History)
4 users (show)

See Also:
Fixed In Version: 21.4-14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 499035 (view as bug list)
Environment:
Last Closed: 2006-03-27 22:57:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2005-12-01 14:07:28 EST
With emacs-21.4-10, load a file into emacs with C-x C-f, type a few 
characters, then type C-x k RET, and emacs will coredump.

It's coredumping at doprint.c:249.  The cause of the coredump is, I believe 
the gcc problem documented in bug 174728.
Comment 1 Jonathan Kamens 2005-12-01 17:00:10 EST
The problem is the -fstack-protector that's being passed to the emacs build, 
presumably from RPM.  If you filter that option from CFLAGS and rebuild emacs, 
it doesn't crash anymore when the above scenario is executed.
Comment 2 Paul Dickson 2005-12-02 05:36:10 EST
I hit this bug too.
Comment 3 Jens Petersen 2005-12-12 02:58:35 EST
Is this still reproducible with current rawhide?

I don't see it with "emacs -nw" nor when running emacs-x over ssh currently.
Comment 4 Jens Petersen 2005-12-12 03:01:54 EST
*** Bug 174899 has been marked as a duplicate of this bug. ***
Comment 5 Jonathan Kamens 2005-12-12 09:48:58 EST
This problem persists for me in emacs-21.4-10.1 when running emacs -nw.
Comment 6 Paul Dickson 2005-12-12 14:22:17 EST
I still have problem with emacs-21.4-10.1, with and without the -nw argument.
Comment 7 Jens Petersen 2005-12-12 23:23:30 EST
rawhide-i386?  Sorry I only tested on x86_64...
Comment 8 Jonathan Kamens 2005-12-13 08:51:55 EST
Yes, i386.
Comment 9 Jens Petersen 2005-12-13 21:38:21 EST
Thanks.  Reproduced on x86_64 console with emacs.i386 too.
Comment 10 Jens Petersen 2005-12-14 03:05:29 EST
[CCing Jakub and redhat-rpm-config owner]

Thanks, Jonathan, for the report and fix.
Should be in emacs-21.4-11.
Comment 11 Jens Petersen 2006-03-27 22:57:02 EST
Fix should be in FC5.

Note You need to log in before you can comment on or make changes to this bug.