Bug 174759 - Provide support for more than 8 logical processors
Provide support for more than 8 logical processors
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Maly
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-01 17:22 EST by Paul Waterman
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-19 15:53:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Waterman 2005-12-01 17:22:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915

Description of problem:
Currently, RHEL 3.0 only supports a maximum of eight logical processors for the 64-bit x86_64 (AMD64/EM64T) architecture. (On the 32-bit x86 architecture, 32 logical processors are supported.)

These limits are outlined on the following Red Hat page:

http://www.redhat.com/en_us/USA/rhel/details/limits/

With the release of new multi-core processors from Intel and AMD, and new hardware from vendors supporting large numbers of processor cores, this limit is quickly becoming problematic.

For example, a multi-processor system containing 4 Intel dual core processors (e.g., Paxville) with hyperthreading enabled will show up as 16 logical processors under Linux. On x86, this works fine, but on x86_64, only 8 logical processors show up, and hyperthreading is effectively disabled.

Worse yet, on a multi-processor system containing 8 AMD dual core processors you effectively lose access to half the cores in the system under x86_64.

Intel and systems vendors assure me that Red Hat is aware of this problem and that fixes are being planned, but I've been unable to locate a bugzilla bug which is tracking this need. Thus, I'm opening this bug. If there is some internal/hidden bug to track this development, please feel free to dupe the bug. (Note that this bug is similar/related to but NOT a duplicate of Bug 147823.)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RHEL 3.0 x86_64 on a system with more than eight logical processors.
2. cat /proc/cpuinfo
  

Actual Results:  Only eight logical processors will be listed.

Expected Results:  All available logical processors should be listed.

Additional info:
Comment 1 Ernie Petrides 2005-12-01 21:44:20 EST
I believe the real limit is 32.  Tim, is this a documentation bug?
Comment 2 Paul Waterman 2005-12-05 12:09:00 EST
Two notes:

1) I was slightly incorrect in my description of the problem. In RHEL *4.0* only
the first eight logical processors are listed (and I've separately opened Bug
174760 regarding that. In RHEL 3.0 the problem is more severe when there are
more than eight logical processors: The kernel won't boot. I've opened Bug
174991 for that bug. If this feature is implemented, it will resolve that bug;
if not, the failure to boot will need to be addressed separately.

2) I'm fairly certain this is NOT a documentation bug. (I've tested it and Sun,
Dell, and Intel have all indicated to me that it's a problem.)
Comment 3 Ernie Petrides 2005-12-05 18:23:05 EST
Reassigning to Jim.
Comment 4 Red Hat Bugzilla 2007-03-18 18:35:49 EDT
User jparadis@redhat.com's account has been closed

Note You need to log in before you can comment on or make changes to this bug.