Bug 17480 - Both graphical and text installation from CD1 of Beta fails
Summary: Both graphical and text installation from CD1 of Beta fails
Status: CLOSED DUPLICATE of bug 17928
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-13 22:31 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-04 16:51:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-09-13 22:31:46 UTC
Every time I install the RedHat 7 beta, when I arrive at "port-
installation operation" (the step that happens just when the file 
installation finish) it goes for a few seconds, than, when the progress 
bar is almost 40% and an error occurs and a popup come out with the 
following dump. This is very annoying because I cannot install Linux.
If u need it my PC is an Acer Laptop (TravelMate 732 TE)

Traceback (innermost last):
  File "/usr/bin/anaconda", line 426, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/text.py", line 1022, in run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/text.py", line 504, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/todo.py", line 1674, in 
doInstall
    stdout = devnull)
  File "/var/tmp/anaconda-7.0//usr/lib/anaconda/iutil.py", line 40, in 
execWithRedirect
    raise RuntimeError, command + " can not be run"
RuntimeError: /usr/sbin/kudzu can not be run

Local variables in innermost frame:
argv: ['/usr/sbin/kudzu', '-q']
root: /mnt/sysimage
stdin: 0
newPgrp: 0
stdout: 16
stderr: 2
command: /usr/sbin/kudzu
searchPath: 0
ignoreTermSigs: 0

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

Comment 1 Need Real Name 2000-09-13 22:41:48 UTC
I forgot something that can be important:
I was doing an install from a CD created with the ISO image found on FTP server

Comment 2 elylevy 2000-09-14 13:29:30 UTC
Happened to me also while I was trying to install through FTP
on a PIII 600 computer with intel onboard network card

Comment 3 Michael Fulbright 2000-09-14 19:06:41 UTC
Are you explicitely NOT installing kudzu? It is required for the install to
complete, and is in our default
component lists.


Comment 4 elylevy 2000-09-14 19:19:22 UTC
actually I chose the everything option in the installation


Comment 5 Need Real Name 2000-09-14 21:47:34 UTC
I've done the custom installation because I've to keep the existing data on the 
other partitions, but didn't explicitely removed kudzu from installation
I tried another installation to see what I usually installed:
 - Print Support
 - X support
 - GNome
 - Toolmail/WWW/News
 - Dos/Win Connectivity
 - Graphic elaboration
 - Multimedia Support
 - LapTop Support
 - Workstation network support
 - Workstation Dialup support
 - Server SMB
 - Workstation network management
 - Authoring/Publishing
 - Emacs
 - Development
 - Utility

Then I went to "detailed package" to see if kudzu is cheched as installed and I 
just find one package with kudzu in it's name.. it was in 
Development/Libraries/kudzu-devel and it was checked, I didn't find anything 
else.



Comment 6 Need Real Name 2000-09-14 21:53:01 UTC
Another annoying thing, but that can be "by design" is that, after the 
installation fails, my CD tray is "locked" and I cannot eject the CD-ROM since 
I don't boot Win2K and access the CD from the File Explorer.
If I try to eject the CD before the tray doesn't come out..

Comment 7 Need Real Name 2000-09-16 18:57:23 UTC
Another thing that might be usefull to help debug the problem.. I decided not 
to make a boot diskette and to install the LILO in the Linux Partition and not 
on the MBR

Comment 8 Michael Fulbright 2000-09-25 20:19:24 UTC
Please try the 7.0 final release which just came out and see if it addresses
these problems.

Comment 9 Michael Fulbright 2000-10-04 16:51:14 UTC
I think this is due to how RPM handles bad packages.

Try downloading the install images again, and be sure to use the 'binary' ftp
option.

*** This bug has been marked as a duplicate of 17928 ***


Note You need to log in before you can comment on or make changes to this bug.