Bug 17928 - Teach RPM to pass exceptions up to anaconda
Teach RPM to pass exceptions up to anaconda
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
: 1569 17480 18550 20084 20339 20723 20728 23583 23755 23901 23964 24926 27390 34173 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-29 22:49 EDT by Norby
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-20 12:55:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anacdump.txt (1.11 KB, text/plain)
2000-09-29 22:51 EDT, Norby
no flags Details

  None (edit)
Description Norby 2000-09-29 22:49:48 EDT
Custom Install, formatted root filesystem.  Only filesystem is / on hda5

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1632, in 
doInstall
    self.writeConfiguration ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1383, in 
writeConfiguration
    self.writeRootPassword ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 660, in 
writeRootPassword
    self.setPassword("root", pure)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1151, in 
setPassword
    stdin = p[0], stdout = devnull)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iutil.py", line 40, in 
execWithRedirect
    raise RuntimeError, command + " can not be run"
RuntimeError: /usr/bin/passwd can not be run

Local variables in innermost frame:
argv: ['/usr/bin/passwd', '--stdin', 'root']
root: /mnt/sysimage
stdin: 22
newPgrp: 0
stdout: 21
stderr: 2
command: /usr/bin/passwd
searchPath: 0
ignoreTermSigs: 0

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Norby 2000-09-29 22:51:16 EDT
Created attachment 3574 [details]
Anacdump.txt
Comment 2 Michael Fulbright 2000-10-02 18:47:22 EDT
Did you happen to not install the passwd package? It is needed.
Comment 3 Norby 2000-10-03 11:45:57 EDT
I did not choose to select individual packages, so I guess the question 
is, "Does the installer install the passwd package by default?"

But seriously, at the point the installer dies, /usr/bin is still the install 
image, isn't it?  If the passwd package is installed, isn't it located in the 
destination mount point?
Comment 4 Norby 2000-10-03 11:48:01 EDT
>Local variables in innermost frame:
>argv: ['/usr/bin/passwd', '--stdin', 'root']
>root: /mnt/sysimage
>stdin: 22
>newPgrp: 0
>stdout: 21
>stderr: 2
>command: /usr/bin/passwd

There is no passwd at /usr/bin at this stage - and if passwd is installed, 
possibly it is at /mnt/sysimage/usr/bin?
Comment 5 Michael Fulbright 2000-10-03 15:32:10 EDT
Related to bug 18201.
Comment 6 Michael Fulbright 2000-10-03 18:11:11 EDT
Yes it should be running /mnt/sysimage/usr/bin/passwd.

Could you try the install again, using the same options, and watch to see if
passwd gets installed, and when the installation of packages is almost complete,
go to virtual console 2 and look in /mnt/sysimage/usr/bin to see if the passwd
binary exists.

Be sure to 'cd  /' when you are done so the installer can umount all mounts
cleanly when it is done.
Comment 7 Norby 2000-10-03 22:12:37 EDT
No, passwd does not get installed.  And I think I've found the problem.

At the error screen, the install pauses.  On console 2, I ran 
rpm -q -p passwd-0.64.1-4.i386.rpm from /mnt/source/RedHat/RPMS.  rpm said that 
package did not appear to be a valid RPM.  So I tried rpm -q -p * and found 
that a lot of the RPMs in there are corrupt.  Including packages like the XFree 
fonts and other handy things.

I had downloaded the ISO from several sites simultaneously with GetRight.  I 
had no problems using this method to get 6.1, so either GetRight screwed up 
(this is a newer version than I used before), there was some kind of transfer 
error on one of the segments that GetRight didn't catch, or there is different 
versions of ISO's on the mirrors.

In either case, NotABug, corrupt CD image.

Maybe I'll just break down and buy the thing! :)

Thanks.
Comment 8 Norby 2000-10-03 22:15:40 EDT
A couple of thoughts:

It might be handy in the future to have the install process be able to tell 
whether or not an RPM is corrupt, rather than just have it skip it altogether.

Your related 18201 sounds like the same thing.

Thanks again!  Sorry to waste your time, you appear busy.
Comment 9 Michael Fulbright 2000-10-04 12:32:37 EDT
We will try to address this in the future by trapping the RPM error - the
current behavior is inadequate.

Sorry for the trouble.
Comment 10 Michael Fulbright 2000-10-04 12:51:09 EDT
*** Bug 17480 has been marked as a duplicate of this bug. ***
Comment 11 Michael Fulbright 2000-10-04 14:25:28 EDT
*** Bug 1569 has been marked as a duplicate of this bug. ***
Comment 12 Michael Fulbright 2000-10-06 15:59:42 EDT
*** Bug 18550 has been marked as a duplicate of this bug. ***
Comment 13 Michael Fulbright 2000-10-31 11:05:58 EST
*** Bug 20084 has been marked as a duplicate of this bug. ***
Comment 14 Michael Fulbright 2000-11-07 10:27:22 EST
*** Bug 20339 has been marked as a duplicate of this bug. ***
Comment 15 Michael Fulbright 2000-11-13 14:15:27 EST
*** Bug 20728 has been marked as a duplicate of this bug. ***
Comment 16 Michael Fulbright 2000-11-13 14:18:21 EST
*** Bug 20723 has been marked as a duplicate of this bug. ***
Comment 17 Michael Fulbright 2001-01-09 11:32:22 EST
*** Bug 23583 has been marked as a duplicate of this bug. ***
Comment 18 Michael Fulbright 2001-01-11 11:57:42 EST
*** Bug 23755 has been marked as a duplicate of this bug. ***
Comment 19 Michael Fulbright 2001-01-15 19:40:40 EST
*** Bug 23964 has been marked as a duplicate of this bug. ***
Comment 20 Michael Fulbright 2001-01-15 19:44:26 EST
*** Bug 23901 has been marked as a duplicate of this bug. ***
Comment 21 Michael Fulbright 2001-01-25 17:35:13 EST
*** Bug 24926 has been marked as a duplicate of this bug. ***
Comment 22 Brent Fox 2001-04-19 23:49:18 EDT
*** Bug 34173 has been marked as a duplicate of this bug. ***
Comment 23 Brent Fox 2001-09-07 12:12:10 EDT
*** Bug 53365 has been marked as a duplicate of this bug. ***
Comment 24 Michael Fulbright 2001-09-18 12:41:19 EDT
*** Bug 27390 has been marked as a duplicate of this bug. ***
Comment 25 Jeremy Katz 2002-03-20 12:55:36 EST
RPM error trapped
Comment 26 Jeremy Katz 2002-04-10 00:39:08 EDT
Verified

Note You need to log in before you can comment on or make changes to this bug.