Bug 1748209 - Please add CPAN's XML::Feed to EPEL-6 and EPEL-7
Summary: Please add CPAN's XML::Feed to EPEL-6 and EPEL-7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-XML-Feed
Version: rawhide
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1763495 1763496 1763497
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-03 07:37 UTC by lars.nooden
Modified: 2019-11-20 00:29 UTC (History)
5 users (show)

Fixed In Version: perl-XML-Feed-0.43-1.el6 perl-XML-Feed-0.59-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-13 11:16:42 UTC
Type: Bug


Attachments (Terms of Use)

Description lars.nooden 2019-09-03 07:37:17 UTC
Description of problem: Please add the CPAN module XML::Feed to EPEL.

It can be found here: https://metacpan.org/pod/XML::Feed

Version-Release number of selected component (if applicable): 

How reproducible:

Every time.  

Steps to Reproduce:
1. sudo yum install perl-XML-Feed

Actual results:

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: repos.lax.quadranet.com
 * epel: mirrors.sonic.net
 * extras: repos.forethought.net
 * updates: linux.mirrors.es.net
No package perl-XML-Feed available.
Error: Nothing to do


Expected results:

I would expect that the requested CPAN package would be found and installed by Yum.  

Additional info:

Comment 1 Emmanuel Seyman 2019-09-08 07:44:59 UTC
My efforts concerning EPEL are mostly focused on EPEL 8.

Would you be willing to maintain the package in EPEL 6/7? If so, I'll need your FAS username to give you commit access.

Comment 2 Emmanuel Seyman 2019-10-17 20:47:11 UTC
A month later, it looks like no one is interested enough in EPEL 6/7 to maintain this package.
If you feel differently, please reopen this bug, asking for commit access.

Comment 3 Paul Howarth 2019-10-19 19:07:16 UTC
OK, I took a look at this today and I'm prepared to do these branches.

I'll need access to these packages of yours Emmanuel:

perl-XML-Feed (el6,epel7)
  Note that the latest viable version of this for EPEL-6 is 0.43 because later versions require XML::RSS ≥ 1.47 and EL-6 ships XML::RSS 1.45

perl-XML-Atom (el6,epel7)
  Note that the latest viable version of this for EPEL-6 is 0.41 because later versions require Module::Build::Tiny, which is not buildable for EPEL-6

perl-URI-Fetch (el6,epel7)

perl-XML-RSS-LibXML (el6,epel7)
  Note that the latest viable version of this for EPEL-6 is 0.3102 because later versions require CPAN::Meta for tooling, which is not buildable for EPEL-6

I will also need to raise branch requests for some other Perl SIG members' packages:

perl-Feed-Find (Jitka: el6,epel7)

perl-DateTime-Format-Flexible (Petr: epel7)

perl-DateTime-Format-Natural (Jitka: epel7)
  This builds OK (with an override for perl-Module-Util) if the Module::Build 0.42 version requirement is patched out of META.*

perl-Module-Util (Jitka: epel7)

Comment 4 Emmanuel Seyman 2019-10-20 07:01:45 UTC
(In reply to Paul Howarth from comment #3)
> 
> I'll need access to these packages of yours Emmanuel:

I've given you commit access to these 4 packages.

Comment 5 Paul Howarth 2019-10-20 11:32:00 UTC
Thanks.

Comment 6 Fedora Update System 2019-10-28 19:13:23 UTC
FEDORA-EPEL-2019-4c2b525cdf has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-4c2b525cdf

Comment 7 Fedora Update System 2019-10-29 04:39:26 UTC
perl-Feed-Find-0.07-22.el6, perl-URI-Fetch-0.13-11.el6, perl-XML-Atom-0.41-18.el6, perl-XML-Feed-0.43-1.el6, perl-XML-RSS-LibXML-0.3102-2.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-4c2b525cdf

Comment 8 Fedora Update System 2019-11-04 17:34:02 UTC
FEDORA-EPEL-2019-9da4e873b0 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-9da4e873b0

Comment 9 Fedora Update System 2019-11-05 01:08:22 UTC
perl-URI-Fetch-0.13-11.el7, perl-XML-Atom-0.42-6.el7, perl-XML-Feed-0.59-4.el7, perl-XML-RSS-LibXML-0.3105-9.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-9da4e873b0

Comment 10 Fedora Update System 2019-11-13 11:16:42 UTC
perl-Feed-Find-0.07-22.el6, perl-URI-Fetch-0.13-11.el6, perl-XML-Atom-0.41-18.el6, perl-XML-Feed-0.43-1.el6, perl-XML-RSS-LibXML-0.3102-2.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2019-11-20 00:29:48 UTC
perl-URI-Fetch-0.13-11.el7, perl-XML-Atom-0.42-6.el7, perl-XML-Feed-0.59-4.el7, perl-XML-RSS-LibXML-0.3105-9.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.