Bug 1748744 - bug-1402841.t-mt-dir-scan-race.t fails spuriously
Summary: bug-1402841.t-mt-dir-scan-race.t fails spuriously
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1749155 1749157 1807748
TreeView+ depends on / blocked
 
Reported: 2019-09-04 06:03 UTC by Ravishankar N
Modified: 2020-02-27 06:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1749155 1749157 1807748 (view as bug list)
Environment:
Last Closed: 2019-09-04 18:29:05 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 23352 0 None Merged tests: fix spurious failure of bug-1402841.t-mt-dir-scan-race.t 2019-09-04 18:29:04 UTC

Description Ravishankar N 2019-09-04 06:03:59 UTC
Description of problem:


    Since commit 600ba94183333c4af9b4a09616690994fd528478, shd starts
    healing as soon is it is toggled from disabled to enabled. This was
    causing the following line in the .t to fail on a 'fast' machine (always
    on my laptop and sometimes on the jenkins slaves).

    EXPECT_NOT "^0$" get_pending_heal_count $V0

    because by the time shd was disabled, the heal was already completed.

Comment 1 Worker Ant 2019-09-04 06:08:55 UTC
REVIEW: https://review.gluster.org/23352 (tests: fix spurious failure of bug-1402841.t-mt-dir-scan-race.t) posted (#1) for review on master by Ravishankar N

Comment 2 Ravishankar N 2019-09-04 06:13:40 UTC
Forgot to add the links to failures in the bug description:
https://build.gluster.org/job/centos7-regression/7743/
https://build.gluster.org/job/centos7-regression/7747/

Comment 3 Worker Ant 2019-09-04 18:29:05 UTC
REVIEW: https://review.gluster.org/23352 (tests: fix spurious failure of bug-1402841.t-mt-dir-scan-race.t) merged (#3) on master by Raghavendra Talur


Note You need to log in before you can comment on or make changes to this bug.