Bug 1807748 - bug-1402841.t-mt-dir-scan-race.t fails spuriously
Summary: bug-1402841.t-mt-dir-scan-race.t fails spuriously
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: 5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ravishankar N
QA Contact:
URL:
Whiteboard:
Depends On: 1748744
Blocks: 1749155 1749157
TreeView+ depends on / blocked
 
Reported: 2020-02-27 06:39 UTC by Ravishankar N
Modified: 2020-02-27 06:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1748744
Environment:
Last Closed: 2020-02-27 06:52:09 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gluster.org Gerrit 24178 0 None Merged tests: fix spurious failure of bug-1402841.t-mt-dir-scan-race.t 2020-02-27 06:52:08 UTC

Description Ravishankar N 2020-02-27 06:39:37 UTC
+++ This bug was initially created as a clone of Bug #1748744 +++

Description of problem:


    Since commit 600ba94183333c4af9b4a09616690994fd528478, shd starts
    healing as soon is it is toggled from disabled to enabled. This was
    causing the following line in the .t to fail on a 'fast' machine (always
    on my laptop and sometimes on the jenkins slaves).

    EXPECT_NOT "^0$" get_pending_heal_count $V0

    because by the time shd was disabled, the heal was already completed.

--- Additional comment from Worker Ant on 2019-09-04 06:08:55 UTC ---

REVIEW: https://review.gluster.org/23352 (tests: fix spurious failure of bug-1402841.t-mt-dir-scan-race.t) posted (#1) for review on master by Ravishankar N

--- Additional comment from Ravishankar N on 2019-09-04 06:13:40 UTC ---

Forgot to add the links to failures in the bug description:
https://build.gluster.org/job/centos7-regression/7743/
https://build.gluster.org/job/centos7-regression/7747/

--- Additional comment from Worker Ant on 2019-09-04 18:29:05 UTC ---

REVIEW: https://review.gluster.org/23352 (tests: fix spurious failure of bug-1402841.t-mt-dir-scan-race.t) merged (#3) on master by Raghavendra Talur

Comment 1 Worker Ant 2020-02-27 06:41:37 UTC
REVIEW: https://review.gluster.org/24178 (tests: fix spurious failure of bug-1402841.t-mt-dir-scan-race.t) posted (#1) for review on release-5 by Ravishankar N

Comment 2 Worker Ant 2020-02-27 06:52:09 UTC
REVIEW: https://review.gluster.org/24178 (tests: fix spurious failure of bug-1402841.t-mt-dir-scan-race.t) merged (#1) on release-5 by Ravishankar N


Note You need to log in before you can comment on or make changes to this bug.