Bug 1748817 - WebKitGTK unable to display pages in accelerated compositing mode
Summary: WebKitGTK unable to display pages in accelerated compositing mode
Keywords:
Status: CLOSED DUPLICATE of bug 1751936
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-04 08:50 UTC by Cédric Bellegarde
Modified: 2019-09-17 12:35 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-17 12:35:00 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
WebKit Project 201505 None None None 2019-09-08 11:57:41 UTC

Description Cédric Bellegarde 2019-09-04 08:50:07 UTC
Description of problem:
Devhelp run but is unable to display any page.

Version-Release number of selected component (if applicable):
devhelp-3.32.0-2.fc31.x86_64

Actual results:
No page displayed

Expected results:
Pages displayed

Additional info:
May need a rebuild against current webkit2gtk3

Comment 1 Cédric Bellegarde 2019-09-04 08:51:29 UTC
Found this on command line:
Cannot create EGL window surface: EGL_BAD_ALLOC

Comment 2 Cédric Bellegarde 2019-09-08 11:57:42 UTC
Related bug report:
https://bugs.webkit.org/show_bug.cgi?id=201505

Comment 3 Michael Catanzaro 2019-09-16 23:03:32 UTC
In the upstream WebKit bug, this was identified as a regression in mesa 19.2.

Kamil, this is another blocker candidate, for the reasons you mentioned in https://bugzilla.redhat.com/show_bug.cgi?id=1750345#c15.

Bug #1751936 is likely a dup of this one (but we can wait for the needinfo there to be certain).

Comment 4 Kamil Páral 2019-09-17 12:35:00 UTC
I'll dupe this one to bug 1751936, because that one was already accepted as a blocker.

*** This bug has been marked as a duplicate of bug 1751936 ***


Note You need to log in before you can comment on or make changes to this bug.