Bug 1751936 - Google account shows just empty window
Summary: Google account shows just empty window
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: webkit2gtk3
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomas Popela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
: 1748817 (view as bug list)
Depends On:
Blocks: F31FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2019-09-13 06:57 UTC by Petr Schindler
Modified: 2019-09-19 01:07 UTC (History)
22 users (show)

Fixed In Version: webkit2gtk3-2.26.0-2.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-19 01:07:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1750345 None CLOSED [abrt] gnome-initial-setup: webkitWebViewBaseMakeGLContextCurrent(): gnome-initial-setup killed by SIGSEGV 2019-09-20 23:16:33 UTC
WebKit Project 201505 None None None 2019-09-17 12:37:21 UTC

Internal Links: 1750345

Description Petr Schindler 2019-09-13 06:57:16 UTC
Description of problem:
When I want to add Google in online account only white window appears instead of login screen. When I move with mouse over the window I can see that cursor changes for text fields, so it appears that it is only problem with rendering as text fields are on proper place.

This also happened to me when I tried to add google account during system's initial setup.

I'd like to mention that when I close this window with 'x' button the gnome settings app crashes on next click - bug 1749709

Version-Release number of selected component (if applicable):
gnome-online-accounts-3.34.0-1.fc31.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Open online accounts
2. Click on Google
3.

Actual results:
White window appears

Expected results:
Google account login screen appears

Additional info:
I propose this as F31 final freeze exception. Google account is quite common so this could concern lot of people.

Comment 1 Debarshi Ray 2019-09-13 11:42:21 UTC
Were you, by any chance, doing this inside a virtual machine? If not, what graphics hardware did you have?

This is almost certainly a WebKitGTK (or underlying graphics) issue. Do various Google domains work in Epiphany (because it's a WebKitGTK browser)?

Comment 2 Michael Catanzaro 2019-09-13 12:35:06 UTC
Try WEBKIT_DISABLE_COMPOSITING_MODE=1. Then when that fixes the issue, you'll have enough info to report to WebKit Bugzilla, where you'll be asked for specific details of your graphics hardware. (This is going to be hardware-specific. Or specific to the particular VM that you're using.)

Testing in Epiphany won't work because we have compositing mode disabled due to it breaking video playback for Exalm.

Comment 3 Kamil Páral 2019-09-16 17:11:09 UTC
We'll provide debugging details, but in general some info is in bug 1750345. Seems to be related to 3D acceleration.

Comment 4 Debarshi Ray 2019-09-16 17:17:53 UTC
From bug 1750345 it looks like we have two different webkitgtk4 bugs here, right?

Comment 5 Michael Catanzaro 2019-09-16 18:18:26 UTC
Yes, bug #1750345 is a crash when leaving compositing mode. This bug is about failure to display web content in compositing mode.

Please check for:

Cannot create EGL window surface: EGL_BAD_ALLOC

on the command line so we can figure out whether this is a dup of bug #1748817.

Comment 6 Geoffrey Marr 2019-09-17 05:47:37 UTC
Discussed during the 2019-09-16 blocker review meeting: [0]

The decision to classify this bug as an "AcceptedBlocker" was made as it violates the following criterion:

"All elements of the default panel (or equivalent) configuration in all release-blocking desktops must function correctly in typical use"

[0] https://meetbot.fedoraproject.org/fedora-blocker-review/2019-09-16/f31-blocker-review.2019-09-16-16.02.txt

Comment 7 Petr Schindler 2019-09-17 07:54:56 UTC
Hi, I hit this when I was going through the initial-setup on my bare machine. I also tested it in virtual machine with the same result.

On my laptop (ThinkPad T540p) there is Intel HD 4600 graphic.

When run with WEBKIT_DISABLE_COMPOSITING_MODE=1 it displays content correctly.

When run normally there is message in terminal:
Cannot create EGL window surface: EGL_BAD_ALLOC

Comment 8 Kamil Páral 2019-09-17 10:13:26 UTC
I can confirm Petr's comment above with my virt-manager VM with 3d acceleration enabled. Same error message EGL_BAD_ALLOC, also works when compositing is disabled (or 3d acceleration is disabled in VM configuration).

Comment 9 Tomas Popela 2019-09-17 10:58:56 UTC
Can someone try to downgrade mesa? At least for a user in https://bugs.webkit.org/show_bug.cgi?id=200856#c18, downgrading mesa fixed the problem for him.

Comment 10 Kamil Páral 2019-09-17 12:33:38 UTC
Yes, downgrading to mesa-19.1.4-1.fc31 fixes the rendering issue. Should we reassign to mesa?

Comment 11 Kamil Páral 2019-09-17 12:35:00 UTC
*** Bug 1748817 has been marked as a duplicate of this bug. ***

Comment 12 Tomas Popela 2019-09-17 12:35:47 UTC
Yes Kamil, I think so.

Comment 13 Kamil Páral 2019-09-17 12:37:22 UTC
"Ok, this is because mesa now fails if eglCreateWindowSurface() is called twice for the same window/pixman. And WebKit is doing that when not using the wpe renderer due to a bug."
https://bugs.webkit.org/show_bug.cgi?id=201505

Comment 14 Tomas Popela 2019-09-17 12:45:21 UTC
Ah, thank you Kamil! Reassigning back and adding it to a build that I'm doing for bug 1750345.

Comment 15 Fedora Update System 2019-09-17 19:19:38 UTC
FEDORA-2019-fef2eda60a has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-fef2eda60a

Comment 16 Fedora Update System 2019-09-18 02:00:39 UTC
webkit2gtk3-2.26.0-2.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-fef2eda60a

Comment 17 František Zatloukal 2019-09-18 10:29:41 UTC
webkit2gtk3-2.26.0-2.fc31 fixes the issue.

Comment 18 Fedora Update System 2019-09-19 01:07:47 UTC
webkit2gtk3-2.26.0-2.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.