Bug 174886 - app-defaults files not being found
app-defaults files not being found
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libXt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
: 174706 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-03 09:15 EST by Bill Crawford
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-20 08:07:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Crawford 2005-12-03 09:15:46 EST
Description of problem:
xterm, when right clicking with ctrl, shows at the top of the vt menu "no
app-defaults" ... app-defaults files are not being found.

Version-Release number of selected component (if applicable):
0.99.2-2

How reproducible:
Run xterm and ctrl-right click.
Comment 1 Mike A. Harris 2005-12-21 05:36:12 EST
Thanks for the report.  Upstream X.Org X11 was installing the app-defaults
files to FHS unfriendly locations.  It's taken a while to get things fixed,
but the X11R7 RC4 release has most if not all of the issues ironed out now.

Please upgrade all packages to the latest in rawhide, and the issue should
probably be resolved now.  Just for documentive purposes, the new proper
location for app-defaults files is %{_datadir}/X11/app-defaults which
expands to /usr/share/X11/app-defaults normally.

Once you've upgraded, please reboot and test any applications that had
app-defaults related problems.  If the xfontsel problem persists, please
update the report with any new details and report back.

Thanks again!
Comment 2 Mike A. Harris 2005-12-21 05:46:14 EST
oops, closed by accident
Comment 3 Mike A. Harris 2005-12-21 07:09:11 EST
*** Bug 174706 has been marked as a duplicate of this bug. ***
Comment 4 Mike A. Harris 2006-01-20 08:07:21 EST
This problem was filed against 0.99.2-2 of Xt, however there have been
a number of updates to the entire X11R7 release since the time this was
filed, many of which dealt with misplaced app-defaults files, or applications
and libs looking in the wrong place for them.

It is currently believed that all such X11R7 libraries and applications present
in rawhide have had this problem resolved for quite some time now.  Please
update to the latest packages, and if the problem is still present, reopen
the bug report and I'll reinvestigate libXt et al.

TIA.

Note You need to log in before you can comment on or make changes to this bug.