Bug 174959 - Upgrade from RH9 to FC4 installer exits abnormally
Upgrade from RH9 to FC4 installer exits abnormally
Status: CLOSED DUPLICATE of bug 169613
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-04 20:32 EST by lyvewyre13
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-06 18:15:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Andaconda Dump File (782.55 KB, text/plain)
2005-12-04 20:32 EST, lyvewyre13
no flags Details

  None (edit)
Description lyvewyre13 2005-12-04 20:32:24 EST
Description of problem:
Initially I attempted to install FC3 but it exited abnormally during the 
install so I upgraded all the firmware for the system BIOS,RAID controller, 
server backplane and attempted the install again with the same results.
RH9 had previoulsy been installed on this server with a different set of drives 
so I did a fresh install of RH9 to see if it also had a problem. It did not so 
I configured some of the services I needed and decided to see if an upgrade to 
FC3 would work but it failed again. I finally attempted FC4 upgrade and it 
initiallly failed but on a second attempt it began installing RPMs and when it 
got to the kernel RPM the install exitied abnormally.
 
During a text-mode installation the screen begins spewing errors about the 
RPMDB being a read-only file system and the server freezes. Upon a third 
attempt the kernel packages install but then the installer exited abnormally 
and gave an andaconda dump file.

Version-Release number of selected component (if applicable):


How reproducible:Everytime


Steps to Reproduce:
1.Boot from CDROM
2.Select Upgrade from RH9 or FC4

  
Actual results:
The text screen begins to display a blur of failed attempts to install RPMs or 
during the install of RPMs the installer exits abnormally

Expected results:
A complete installation

Additional info:
PowerEdge 2400 Dual Processor 500mhz Pentium III (Coppermine)
512MB RAM
Embedded Server Management v5.39
System Backplane v5.47
RAID-5 Container 164GB disk space
NEC CDROM SCSI

I used the integrated SCSI controller and an Adaptec 2940 PCI controller for 
the CDROM. I also used an external Toshiba SCSI CDROM. The results were the 
same with either setup.
Comment 1 lyvewyre13 2005-12-04 20:32:25 EST
Created attachment 121823 [details]
Andaconda Dump File
Comment 2 lyvewyre13 2005-12-04 21:39:01 EST
I attempted another install and switched consoles when the install began to 
fail and noted the following error:
<3> scsi1 (0:0) rejecting I/O to offline device

I found this URL on the issue http://lkml.org/lkml/2005/1/14/252

The aacraid driver should be the latest one since I am using FC4.
Comment 3 lyvewyre13 2005-12-05 09:28:46 EST
The Perc2/si controller BIOS is 2.84 Build 6098.
I opened DMESG and it makes a reference to the SCSI device using a depreciated 
SCSI ioctl to convert it to SG_IO
Comment 4 Dave Jones 2005-12-06 18:15:02 EST
installation issues are tricky, as a kernel update isn't really any help to you.
However the bug I'm duping this against has a pointer to some unofficial FC4.2
ISO's which are FC4+updates. That may have a new enough kernel to have this fixed.

Good luck.


*** This bug has been marked as a duplicate of 169613 ***

Note You need to log in before you can comment on or make changes to this bug.