Bug 174970 - Problem in OOcalc while inputing Indic numbers !
Problem in OOcalc while inputing Indic numbers !
Status: CLOSED DUPLICATE of bug 142712
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openoffice.org (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-05 03:45 EST by Ankit Patel
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-20 04:04:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Image taken before pressing Tab/Enter while inputing indic numbers. (86.62 KB, image/png)
2005-12-05 03:47 EST, Ankit Patel
no flags Details
Image taken after pressing Tab/Enter while inputing indic numbers. (90.13 KB, image/png)
2005-12-05 03:48 EST, Ankit Patel
no flags Details
Image taken before pressing Tab/Enter while inputing indic numbers with characters. (89.28 KB, image/png)
2005-12-05 03:49 EST, Ankit Patel
no flags Details
Image taken after pressing Tab/Enter while inputing indic numbers with characters. (89.55 KB, image/png)
2005-12-05 03:49 EST, Ankit Patel
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 41672 None None None Never

  None (edit)
Description Ankit Patel 2005-12-05 03:45:02 EST
Description of problem:
When you type indic numbers in OOcalc it shows them perfectly. But if you press
Tab/Enter to move on another cell OOcalc shows them in English.

And the strage thing is if you input any input alphabet/character altogether
with numbers then it shows everything perfectly after pressing Tab/Enter and
before pressing Tab/Enter.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-24.6.0.EL4

How reproducible:
Your interface language should be any of the indic languages, otherwise you
can't be able to input an indic language. That's also one bug.


Steps to Reproduce:
1.Open oocalc
2.press Ctl+Space OR Shift+Space to enable indic keyboard for input
3.Click on any of the cells of opened spreadsheet.
4.try typing indic numbers
5.press Tab/Enter and see what happens
  
Actual results:
It shows numbers in English after pressing Tab/Enter.


Expected results:
It should show numbers in indic language only anytime (Before pressing Tab/Enter
OR After pressing Tab/Enter).


Additional info:
Comment 1 Ankit Patel 2005-12-05 03:47:03 EST
Created attachment 121837 [details]
Image taken before pressing Tab/Enter while inputing indic numbers.
Comment 2 Ankit Patel 2005-12-05 03:48:40 EST
Created attachment 121838 [details]
Image taken after pressing Tab/Enter while inputing indic numbers.
Comment 3 Ankit Patel 2005-12-05 03:49:16 EST
Created attachment 121839 [details]
Image taken before pressing Tab/Enter while inputing indic numbers with characters.
Comment 4 Ankit Patel 2005-12-05 03:49:53 EST
Created attachment 121840 [details]
Image taken after pressing Tab/Enter while inputing indic numbers with characters.
Comment 5 Ankit Patel 2005-12-05 03:51:23 EST
I have attached screenshots which will help to understand the problem quickly...
Comment 7 Caolan McNamara 2005-12-20 04:04:13 EST

*** This bug has been marked as a duplicate of 142712 ***

Note You need to log in before you can comment on or make changes to this bug.